Project

General

Profile

Bug #19753

Deny reservation if expected backfill size would put us over backfill_full_ratio

Added by David Zafman over 2 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Backfill/Recovery
Target version:
-
Start date:
04/24/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
OSD
Pull request ID:

Description

We currently just check the full status based on disk usage. We need to adjust for the amount of data expected less the data already present.

Need to add the pg stat total in the reservation request?


Related issues

Related to RADOS - Bug #39383: Too much log output generated from PrimaryLogPG::do_backfill() Resolved 04/18/2019
Blocked by RADOS - Bug #24801: PG num_bytes becomes huge Resolved 07/06/2018

History

#1 Updated by Greg Farnum about 2 years ago

  • Project changed from Ceph to RADOS
  • Category set to Backfill/Recovery
  • Component(RADOS) OSD added

#2 Updated by David Zafman about 1 year ago

  • Status changed from New to In Progress

#3 Updated by David Zafman about 1 year ago

  • Blocked by Bug #24801: PG num_bytes becomes huge added

#5 Updated by Neha Ojha 7 months ago

  • Status changed from In Progress to Testing

#6 Updated by David Zafman 7 months ago

  • Status changed from Testing to Resolved

#7 Updated by imirc tw 4 months ago

during backfilling after a failed disk the log files get spammed with do_backfill messages. log files easily grow beyond several GiB within hours

this is caused by https://github.com/ceph/ceph/pull/22797/files#diff-fb41013d27e932534adb50eb3de2aaa5R4273

is this expected behavior or is the log level on the dout too low?

#8 Updated by David Zafman 4 months ago

A couple of dout(0) should be dout(20) or some dout(10) for some less repetitive ones.

#9 Updated by imirc tw 4 months ago

would save a lot of diskspace if you could fix that :)

#10 Updated by David Zafman 4 months ago

  • Related to Bug #39383: Too much log output generated from PrimaryLogPG::do_backfill() added

#11 Updated by David Zafman 4 months ago

  • Pull request ID set to 22797

Also available in: Atom PDF