Project

General

Profile

Bug #19553

tasks/reg11184.py: does not wait for mgr to see new pgs

Added by Sage Weil over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Immediate
Assignee:
-
Category:
-
Target version:
-
Start date:
04/08/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

2017-04-07T22:48:53.305 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/run_tasks.py", line 86, in run_tasks
    manager = run_one_task(taskname, ctx=ctx, config=config)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/run_tasks.py", line 65, in run_one_task
    return task(**kwargs)
  File "/home/teuthworker/src/github.com_ceph_ceph-c_wip-sage-testing2/qa/tasks/reg11184.py", line 67, in task
    divergent = manager.get_pg_primary('foo', 0)
  File "/home/teuthworker/src/github.com_ceph_ceph-c_wip-sage-testing2/qa/tasks/ceph_manager.py", line 1318, in get_pg_primary
    assert False
AssertionError

/a/sage-2017-04-07_19:56:10-rados-wip-sage-testing2---basic-smithi/997670

it creates pool foo (poolid 1), then does get_primary, which does a pg dump (no 1.x pgs yet on the mgr) and osd dump (to translate foo -> 1), then fails teh assertion because it didn't see the pg in pg dump.

i think we need a general method to wait for mgr to see new pgs?


Related issues

Related to Messengers - Bug #20503: not all PGs active+clean in rados/singleton/{all/reg11184.yaml msgr-failures/many.yaml msgr/random.yaml objectstore/filestore-xfs.yaml rados.yaml} Duplicate 07/05/2017
Duplicates Ceph - Bug #19594: assert manager.pg_inconsistent(pool, 0) from repair_test.yaml Resolved 04/12/2017

History

#1 Updated by Kefu Chai over 2 years ago

  • Duplicates Bug #19594: assert manager.pg_inconsistent(pool, 0) from repair_test.yaml added

#2 Updated by Kefu Chai over 2 years ago

  • Status changed from New to Duplicate

#3 Updated by Sage Weil about 2 years ago

  • Related to Bug #20503: not all PGs active+clean in rados/singleton/{all/reg11184.yaml msgr-failures/many.yaml msgr/random.yaml objectstore/filestore-xfs.yaml rados.yaml} added

Also available in: Atom PDF