Project

General

Profile

Bug #1936

teuthology: github downtime -> failed runs

Added by Sage Weil almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
qa
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

we should use a github mirror for anything on github. maybe we can/should piggyback off whatever carl set up.

History

#1 Updated by Sage Weil almost 8 years ago

  • Status changed from New to 7

I set up github mirrors for ceph.git, ceph-qa-chef.git, and s3-tests.git. They are at ceph.newdream.net/git, and updated via a cronjob for the sage user at ~/update_git_mirrors.sh every 15 minutes

#!/bin/sh

cd /git
for f in ceph.git ceph-qa-chef.git s3-tests.git
do
  test -d $f && ( cd $f && git fetch && git update-server-info )
done

Let's see if we see and other similar failures during the nightlies.

#2 Updated by Greg Farnum almost 8 years ago

Is this going to be okay if the update hangs in the middle and then qa clones the repository?

#3 Updated by Sage Weil almost 8 years ago

  • Status changed from 7 to Resolved

#4 Updated by Anonymous almost 8 years ago

Greg Farnum wrote:

Is this going to be okay if the update hangs in the middle and then qa clones the repository?

Git updates are atomic, so nothing will fail just because an update is in progress.

However, nothing here guarantees that the mirror will keep updating, either. "git fetch" from github sometimes hangs indefinitely.

Also available in: Atom PDF