Project

General

Profile

Bug #19018

rgw_file: fix marker computation

Added by Matt Benjamin almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
jewel kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

The underlying type of RGWFileHandle::Directory::marker_cache (dirent_string) was not correct for storing object markers, which have type rgw_obj_key. Since an rgw_obj_key can represent a string via {name=s, instance=""}, just store a flat mapping of uint64_t->rgw_obj_key.

Secondarily, always use the value of next_marker as the marker (works for RGWListBuckets and RGWListBucket).


Related issues

Copied to rgw - Backport #19161: jewel: rgw_file: fix marker computation Resolved
Copied to rgw - Backport #19162: kraken: rgw_file: fix marker computation Resolved

History

#1 Updated by Matt Benjamin almost 6 years ago

  • Status changed from In Progress to Pending Backport

#2 Updated by Matt Benjamin almost 6 years ago

  • Backport changed from jewel to jewel kraken

#3 Updated by Nathan Cutler over 5 years ago

#4 Updated by Nathan Cutler over 5 years ago

  • Copied to Backport #19162: kraken: rgw_file: fix marker computation added

#5 Updated by Nathan Cutler over 5 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF