Project

General

Profile

Backport #18724

jewel: osd: calc_clone_subsets misuses try_read_lock vs missing

Added by Nathan Cutler over 3 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Normal
Target version:
-
Release:
jewel
Crash signature:


Related issues

Copied from Ceph - Bug #18583: osd: calc_clone_subsets misuses try_read_lock vs missing Resolved 01/18/2017

History

#1 Updated by Nathan Cutler over 3 years ago

  • Copied from Bug #18583: osd: calc_clone_subsets misuses try_read_lock vs missing added

#2 Updated by Alexey Sheplyakov over 3 years ago

  • Status changed from New to In Progress

#3 Updated by Nathan Cutler over 3 years ago

  • Description updated (diff)
  • Assignee set to Alexey Sheplyakov

#4 Updated by Nathan Cutler over 3 years ago

  • Status changed from In Progress to Resolved
  • Target version set to v10.2.6

#5 Updated by Samuel Just over 3 years ago

  • Status changed from Resolved to New

I have reverted this backport, it needs to be backported with http://tracker.ceph.com/issues/18809 as well.

#6 Updated by Nathan Cutler over 3 years ago

  • Description updated (diff)

#7 Updated by Nathan Cutler over 3 years ago

  • Target version deleted (v10.2.6)

#8 Updated by Nathan Cutler over 3 years ago

  • Assignee deleted (Alexey Sheplyakov)

#9 Updated by Shinobu Kinjo over 3 years ago

  • Assignee set to Shinobu Kinjo

#10 Updated by Shinobu Kinjo over 3 years ago

  • Description updated (diff)
  • Status changed from New to In Progress

#11 Updated by Shinobu Kinjo over 3 years ago

Cherry-picked commit:
--91b74235027c8a4872dcab6b37767b12c3267061

#13 Updated by Shinobu Kinjo over 3 years ago

@Nathan Should this backport request be achieved?

I'm asking because this backport request is really confusing because:

C#7 in 18583:

Backport changed from kraken(along with 17831) to kraken(along with 17831), jewel(along with 17831)

But

C#21 in 17831:

Backport deleted (kraken,jewel)

http://tracker.ceph.com/issues/18927 and http://tracker.ceph.com/issues/18809 were caused by this series, I don't think we should backport it.

#14 Updated by Shinobu Kinjo over 3 years ago

  • Description updated (diff)

#15 Updated by Shinobu Kinjo over 3 years ago

Please let me close the PR for backporting.

#16 Updated by Shinobu Kinjo over 3 years ago

  • Status changed from In Progress to New

#17 Updated by Shinobu Kinjo over 3 years ago

  • Assignee deleted (Shinobu Kinjo)

#18 Updated by Shinobu Kinjo over 3 years ago

  • Description updated (diff)
  • Status changed from New to In Progress

#19 Updated by Shinobu Kinjo over 3 years ago

  • Assignee set to Shinobu Kinjo

#20 Updated by Nathan Cutler about 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Shinobu Kinjo to Alexey Sheplyakov
  • Target version set to v10.2.8

#21 Updated by Nathan Cutler about 3 years ago

  • Status changed from Resolved to Rejected
  • Target version deleted (v10.2.8)

Also available in: Atom PDF