Project

General

Profile

Bug #18470

rgw: Bucket check doesn't work as expected

Added by zhang sw over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Use "radosgw-admin bucket check --bucket=test --fix " to check bucket's index doesn't work as expected. This command will remove valid index. After this command operated, only multipart upload object which hasn't been completed will remain in bucket index. And Other object will be removed from index.


Related issues

Copied to rgw - Backport #20895: jewel: rgw: Bucket check doesn't work as expected Resolved

History

#2 Updated by Nathan Cutler about 3 years ago

  • Project changed from Ceph to rgw
  • Status changed from New to Fix Under Review

#3 Updated by Pavan Rallabhandi almost 3 years ago

The original regression has been introduced via https://github.com/ceph/ceph/pull/6501 and is present in Jewel 10.2.7. We should have this backported to Jewel since http://tracker.ceph.com/issues/20380 would introduce stale bucket index entries and running bucket check would be catastrophical without this tracker being backported to Jewel.

#4 Updated by Nathan Cutler almost 3 years ago

  • Backport set to jewel

#5 Updated by Nathan Cutler almost 3 years ago

  • Status changed from Fix Under Review to Pending Backport

#6 Updated by Nathan Cutler almost 3 years ago

  • Copied to Backport #20895: jewel: rgw: Bucket check doesn't work as expected added

#7 Updated by Nathan Cutler almost 3 years ago

I created the backport tracker http://tracker.ceph.com/issues/20895 - anyone want to give it a try? (Don't forget to use "git cherry-pick -x" and describe how you resolved the conflict.)

#8 Updated by Nathan Cutler over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF