Project

General

Profile

Bug #18247

Changing 'rbd_default_features' to a string breaks Cinder

Added by Jason Dillaman over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Urgent
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

https://github.com/openstack/cinder/blob/master/cinder/volume/drivers/rbd.py#L152

The Cinder driver casts the now string default feature set to an int, which no longer works. This change needs to be fixed prior to the kraken release.

History

#1 Updated by Jason Dillaman over 3 years ago

... and most likely Nova and Glance as well since they have the same copy-pasted code.

#2 Updated by Jason Dillaman over 3 years ago

  • Status changed from In Progress to Fix Under Review

#3 Updated by Mykola Golub over 3 years ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Nathan Cutler over 3 years ago

  • Backport set to jewel

#5 Updated by Jason Dillaman over 3 years ago

  • Status changed from Pending Backport to Resolved
  • Backport deleted (jewel)

Also available in: Atom PDF