Project

General

Profile

Backport #18193

jewel: transient jerasure unit test failures

Added by Loïc Dachary over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Release:
jewel
Crash signature (v1):
Crash signature (v2):


Related issues

Copied from Ceph - Bug #17762: transient jerasure unit test failures Resolved 10/13/2016

History

#1 Updated by Loïc Dachary over 4 years ago

  • Copied from Bug #17762: transient jerasure unit test failures added

#2 Updated by Nathan Cutler over 4 years ago

  • Status changed from New to Need More Info
  • Assignee set to Kefu Chai

Kefu: one of the commits in this patchset removes "int main()" from a bunch of test programs. I suspect that this is a cmake-specific change and that "int main()" is still needed in jewel, but I'm not sure so I'm assigning to you to clarify.

Also, do you think this is really worth backporting to jewel? The changes are pretty extensive.

#3 Updated by Kefu Chai about 4 years ago

Nathan, sorry, i just noticed your inquiry.

regarding to the removed main(), please see https://github.com/ceph/ceph/pull/11733/commits/cb1cda96713b2ec0f6418c4cbe3d964c2020729c#diff-f20df8ef28538009594974bd56764285

"unit.h" is included in the files where main() is removed, so it will take care of this. and it's not the a cmake-specific change.

right, the change is pretty extensive. and it fixes the problem we run into when the program exits. so i am fine if you think we should not backport it. but the test failure is always annoying, every time we spot it (even in an released branch), we need to root cause it or at least try to recall if it's a known one. and this unit test failure will stay with us for around two years (two LTS releases).

#4 Updated by Kefu Chai about 4 years ago

  • Assignee changed from Kefu Chai to Nathan Cutler

#5 Updated by Nathan Cutler about 4 years ago

  • Status changed from Need More Info to New

#6 Updated by Nathan Cutler about 4 years ago

@Kefu If there is no "more minimal" way to fix the test failure in jewel, then I guess we'll have to take it? I guess it's OK since the changes are only in unit test code and are tested by running make check?

#7 Updated by Nathan Cutler about 4 years ago

  • Description updated (diff)
  • Status changed from New to In Progress

#8 Updated by Nathan Cutler about 4 years ago

  • Status changed from In Progress to Resolved
  • Target version set to v10.2.8

Also available in: Atom PDF