Project

General

Profile

Bug #18047

assertion in MDSMap::get_up_features()

Added by Zheng Yan about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

     0> 2016-11-28 11:44:31.396479 7f6c49d05700 -1 /home/zhyan/Ceph/ceph/src/mds/MDSMap.h: In function 'uint64_t MDSMap::get_up_features()' thread 7f6c49d05700 time 2016-11-28 11:44:31.377558
/home/zhyan/Ceph/ceph/src/mds/MDSMap.h: 386: FAILED assert(q != mds_info.end())

 ceph version 11.0.2-1785-g83230e0 (83230e003d364bc9d1b0ceef60c4b6cc09e2fb7b)
 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x8a) [0x562bb3e1d35a]
 2: (MDLog::_submit_thread()+0xc27) [0x562bb3ce8cc7]
 3: (MDLog::SubmitThread::entry()+0xd) [0x562bb3a71bed]
 4: (()+0x75ca) [0x7f6c54d745ca]
 5: (clone()+0x6d) [0x7f6c53be10ed]

looks like the log submit was accessing the mdsmap while the mdsmap was being modified.

History

#1 Updated by Zheng Yan about 6 years ago

  • Status changed from New to Fix Under Review

#2 Updated by Zheng Yan almost 6 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF