Project

General

Profile

Bug #1804

filestore: unexpected EINVAL

Added by Josh Durgin almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
OSD
Target version:
Start date:
12/07/2011
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Core file and binary are on gitbuilder-gcov-amd64:~/bug_1804.
The data is still on sepia24 for inspection.

2011-12-06 18:19:07.453196 7f7974722700 filestore(/tmp/cephtest/data/osd.0.data)  error error 22: Invalid argument not handled
os/FileStore.cc: In function 'unsigned int FileStore::_do_transaction(ObjectStore::Transaction&, uint64_t)', in thread '7f7974722700'
os/FileStore.cc: 2412: FAILED assert(0 == "unexpected error")
 ceph version 0.39-47-g33753c8 (commit:33753c82af257c14baae1a7bf00e6dc492a93fef)
 1: (FileStore::_do_transaction(ObjectStore::Transaction&, unsigned long)+0x37f1) [0x7f8441]
 2: (FileStore::do_transactions(std::list<ObjectStore::Transaction*, std::allocator<ObjectStore::Transaction*> >&, unsigned long)+0xb8) [0x7fb6a8]
 3: (FileStore::_do_op(FileStore::OpSequencer*)+0x203) [0x7c5f03]
 4: (FileStore::OpWQ::_process(FileStore::OpSequencer*)+0x15) [0x801fb5]
 5: (ThreadPool::WorkQueue<FileStore::OpSequencer>::_void_process(void*)+0x12) [0x7fcc22]
 6: (ThreadPool::worker()+0x7e3) [0x6999e3]
 7: (ThreadPool::WorkThread::entry()+0x15) [0x5c14f5]
 8: (Thread::_entry_func(void*)+0x12) [0x624a32]
 9: (()+0x7971) [0x7f797dba6971]
 10: (clone()+0x6d) [0x7f797c23192d]

History

#1 Updated by Sage Weil almost 8 years ago

  • translation missing: en.field_position set to 19

#2 Updated by Sage Weil almost 8 years ago

as of 7133a2faf0ae0710b7cbd9801c64767172d48faf we dump the failed transaction to the log.

#3 Updated by Sage Weil almost 8 years ago

  • Status changed from New to Need More Info

#4 Updated by Sage Weil almost 8 years ago

My money is that this is caused by #1759. Which hopefully means that the qa suite will eventually trigger the new asserts in master...

#5 Updated by Sage Weil almost 8 years ago

  • translation missing: en.field_position deleted (19)
  • translation missing: en.field_position set to 30

#6 Updated by Sage Weil almost 8 years ago

  • Status changed from Need More Info to Closed

ok, i'm going to assume this was the mds trucnate thing and close it out. we can reopen later if it crops up again!

Also available in: Atom PDF