Project

General

Profile

Bug #17923

tests: ceph-disk.sh fails on py34

Added by Loïc Dachary about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

https://pypi.python.org/pypi/tox/2.5.0 published today made it so an environment with no action fails where it previously did not

https://jenkins.ceph.com/job/ceph-pull-requests/14217/console

ERROR: Commands not specified. Please update relevant section of /home/jenkins-build/build/workspace/ceph-pull-requests/src/ceph-disk/tox.ini
py35 create: /home/jenkins-build/build/workspace/ceph-pull-requests/src/ceph-disk/.tox/py35
ERROR: InterpreterNotFound: python3.5
py36 create: /home/jenkins-build/build/workspace/ceph-pull-requests/src/ceph-disk/.tox/py36
ERROR: InterpreterNotFound: python3.6
<?pre>

Related issues

Related to Ceph - Bug #43100: luminous: ceph-detect-init tox tests fail due to problem with py3 dependencies in old distro Resolved
Duplicated by Ceph - Bug #17900: make check: run-tox-ceph-disk failure Duplicate 11/14/2016

History

#1 Updated by Loïc Dachary about 6 years ago

  • Backport set to jewel

#2 Updated by Loïc Dachary about 6 years ago

  • Subject changed from tests: ceph-disk fails on py34 to tests: ceph-disk.sh fails on py34

#3 Updated by Loïc Dachary about 6 years ago

  • Status changed from 12 to Pending Backport

#4 Updated by Nathan Cutler about 6 years ago

  • Duplicated by Bug #17900: make check: run-tox-ceph-disk failure added

#6 Updated by Loïc Dachary about 6 years ago

  • Status changed from Pending Backport to Resolved
  • Backport deleted (jewel)

the problem was introduced in master, it does not exist in jewel

#7 Updated by Nathan Cutler about 3 years ago

  • Related to Bug #43100: luminous: ceph-detect-init tox tests fail due to problem with py3 dependencies in old distro added

Also available in: Atom PDF