Project

General

Profile

Bug #17747

ceph-mds: remove "--journal-check" help text

Added by Fran├žois Blondel about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Administration/Usability
Target version:
-
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
fs
Component(FS):
MDS
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Hi,

running ceph-mds -d -i ceph --journal-check 0 gives me following input:

--conf/-c FILE    read configuration from the given configuration file
--id/-i ID set ID portion of my name
--name/-n TYPE.ID set name
--cluster NAME set cluster name (default: ceph)
--setuser USER set uid to user or uid (and gid to user's gid)
--setgroup GROUP set gid to group or gid
--version show version and quit
-d                run in foreground, log to stderr.
-f run in foreground, log to usual location.
--debug_ms N set message debug level (e.g. 1)
2016-10-31 10:44:07.101716 7f622f8c6180 0 ceph version 10.2.3 (ecc23778eb545d8dd55e2e4735b53cc93f92e65b), process ceph-mds, pid 84116
2016-10-31 10:44:07.101735 7f622f8c6180 -1 Error: can't understand argument: --journal-check

2016-10-31 10:44:07.101739 7f622f8c6180 -1 usage: ceph-mds -i name [flags] [[--journal_check rank]|[--hot-standby][rank]]
-m monitorip:port
connect to monitor at given address
--debug_mds n
debug MDS level (e.g. 10)
--journal-check rank
replay the journal for rank, then exit
--hot-standby rank
start up as a hot standby for rank

Running ceph-mds -d -i ceph works without issue. (and worked some weeks, running my test instance of CephFS.) (I am trying to run this command because i got " mds rank 0 has failed / mds cluster is degraded ", probably because of a full OSD.

In the documentation is to be found "--journal-check" as well as "--journal_check".
I tried both, same result (Error: can't understand argument: ).
The code and the documentation should be homogenized.

Many thanks !

History

#1 Updated by Fran├žois Blondel about 6 years ago

running ceph-mds -d -i ceph --journal-check 0 gives me following output:

--conf/-c FILE    read configuration from the given configuration file
--id/-i ID set ID portion of my name
--name/-n TYPE.ID set name
--cluster NAME set cluster name (default: ceph)
--setuser USER set uid to user or uid (and gid to user's gid)
--setgroup GROUP set gid to group or gid
--version show version and quit
-d run in foreground, log to stderr.
-f run in foreground, log to usual location.
--debug_ms N set message debug level (e.g. 1)
2016-10-31 10:44:07.101716 7f622f8c6180 0 ceph version 10.2.3 (ecc23778eb545d8dd55e2e4735b53cc93f92e65b), process ceph-mds, pid 84116
2016-10-31 10:44:07.101735 7f622f8c6180 -1 Error: can't understand argument: --journal-check
2016-10-31 10:44:07.101739 7f622f8c6180 -1 usage: ceph-mds -i name [flags] [[--journal_check rank]|[--hot-standby[rank]]
-m monitorip:port
connect to monitor at given address
--debug_mds n
debug MDS level (e.g. 10)
--journal-check rank
replay the journal for rank, then exit
--hot-standby rank
start up as a hot standby for rank

Running "ceph-mds -d -i ceph" works without issue. (and worked some weeks, running my test instance of CephFS.)
I am trying to run this command because I got "mds rank 0 has failed / mds cluster is degraded", probably because of a full OSD.

In the documentation is to be found "--journal-check" as well as "--journal_check".
I tried both, same results. The code and the documentation should be homogenized.

Many thanks !

#2 Updated by Greg Farnum about 6 years ago

  • Project changed from Ceph to CephFS
  • Subject changed from ceph-mds --journal-check or --journal_check to ceph-mds: remove "--journal-check" help text
  • Category set to Administration/Usability
  • Source changed from other to Community (user)
  • Component(FS) MDS added

You should use the cephfs-journal-tool for dealing with this stuff now. The journal-check oneshot-replay mode got removed in commit:edfda9c6b0a0c8b75ebff5f06017aa475339b1fd.

#3 Updated by Nathan Cutler about 6 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Nathan Cutler

#4 Updated by Nathan Cutler about 6 years ago

  • Status changed from Fix Under Review to Resolved

#5 Updated by Nathan Cutler about 6 years ago

  • Status changed from Resolved to Fix Under Review

Oops, forgot to clean up the manpage as well. Follow-up PR: https://github.com/ceph/ceph/pull/11912

#6 Updated by John Spray about 6 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF