Project

General

Profile

Bug #17330

update_features API needs to support backwards/forward compatibility

Added by Jason Dillaman almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Attempting to disable exclusive lock using a Jewel+ client against an Infernalis OSD will result in an error. Since Infernalis is EOL, handle this condition within the librbd client (until after upgrades from Infernalis are no longer supported) and also prevent this in the future within the cls method.


Related issues

Copied to rbd - Backport #17404: jewel: update_features API needs to support backwards/forward compatibility Resolved

History

#1 Updated by Jason Dillaman almost 4 years ago

  • Status changed from In Progress to Fix Under Review

#2 Updated by Mykola Golub almost 4 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Loic Dachary almost 4 years ago

  • Copied to Backport #17404: jewel: update_features API needs to support backwards/forward compatibility added

#4 Updated by Loic Dachary over 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF