Project

General

Profile

Bug #1733

rados bench duration can be ignored

Added by Josh Durgin over 9 years ago. Updated over 9 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Sometimes a thrashing run with rados bench will continue indefinitely, with rados bench continuing to write after its timeout has expired.

History

#1 Updated by Greg Farnum over 9 years ago

Is it generating new writes, or waiting for old writes to complete?

The time you give rados bench was never intended to be an absolute upper-limit; that's the point at which it stops sending new writes to the OSDs — but then it waits until all its old writes have completed before exiting.

#2 Updated by Sage Weil over 9 years ago

  • translation missing: en.field_position set to 3

#3 Updated by Sage Weil over 9 years ago

  • Priority changed from Normal to High

#4 Updated by Josh Durgin over 9 years ago

  • Status changed from New to Duplicate

Probably caused by #1351.

Also available in: Atom PDF