Project

General

Profile

Bug #17087

LibRadosIo.ReadTimeout fails in api_io in rados/test.sh

Added by Kefu Chai almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

see http://qa-proxy.ceph.com/teuthology/kchai-2016-08-21_09:15:16-rados-master---basic-mira/378047/teuthology.log

2016-08-21T09:35:11.812 INFO:tasks.workunit.client.0.mira117.stdout:                   api_io: [ RUN      ] LibRadosIo.ReadTimeout
2016-08-21T09:35:11.812 INFO:tasks.workunit.client.0.mira117.stdout:                   api_io: /srv/autobuild-ceph/gitbuilder.git/build/out~/ceph-11.0.0-1665-g42a42c2/src/test/librados/io.cc:57: Failure
2016-08-21T09:35:11.812 INFO:tasks.workunit.client.0.mira117.stdout:                   api_io: Expected: (0) != (rados_connect(cluster)), actual: 0 vs 0
2016-08-21T09:35:11.812 INFO:tasks.workunit.client.0.mira117.stdout:                   api_io: [  FAILED  ] LibRadosIo.ReadTimeout (3035 ms)

and quite a few tests failed in http://pulpito.ceph.com/kchai-2016-08-20_18:41:17-rados-wip-kefu-testing---basic-mira/ due to this problem.

History

#1 Updated by Kefu Chai almost 4 years ago

  • Description updated (diff)

#2 Updated by Kefu Chai almost 4 years ago

  • Status changed from New to Fix Under Review

#3 Updated by Josh Durgin almost 4 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF