Project

General

Profile

Bug #17025

radosgw-admin-data-sync fails because of data_extra_pool

Added by Orit Wasserman almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

data_extra_pool is per zone.

http://qa-proxy.ceph.com/teuthology/loic-2016-08-12_08:10:12-rgw-jewel-backports---basic-smithi/359320/teuthology.log

2016-08-12T08:48:23.885 INFO:tasks.util.rgw: json result: {u'data': {u'attrs': [{u'val': u'AgJtAAAAAwIOAAAAAwAAAGZvbwMAAABGb28DA1MAAAABAQAAAAMAAABmb28PAAAAAQAAAAMAAABmb28EAy4AAAACAgQAAAAAAAAAAwAAAGZvbwAAAAAAAAAAAgIEAAAADwAAAAMAAABGb28AAAAAAAAAAA==', u'key': u'user.rgw.acl'}, {u'val': u'', u'key': u'user.rgw.idtag'}, {u'val': u'', u'key': u'user.rgw.manifest'}], u'bucket_info': {u'has_instance_obj': u'true', u'has_website': u'false', u'swift_versioning': u'false', u'bucket': {u'name': u'mybar', u'bucket_id': u'r0z0.4146.1', u'marker': u'r0z0.4146.1', u'data_extra_pool': u'.region0.r0z1.data_extra_pool', u'pool': u'.region0.r0z1.data_pool', u'index_pool': u'.region0.r0z1.index_pool'}, u'bi_shard_hash_type': 0, u'creation_time': u'0.000000', u'quota': {u'max_objects': -1, u'enabled': False, u'max_size_kb': -1}, u'flags': 0, u'swift_ver_location': u'', u'owner': u'foo', u'requester_pays': u'false', u'zonegroup': u'region0', u'placement_rule': u'default_placement', u'num_shards': 0}}, u'ver': {u'tag': u'_ULKFEsWDkO1MTMfq5zsPZI2', u'ver': 1}, u'key': u'bucket.instance:mybar:r0z0.4146.1', u'mtime': u'2016-08-12 08:47:20.050731Z'}
2016-08-12T08:48:23.885 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 66, in run_tasks
manager = run_one_task(taskname, ctx=ctx, config=config)
File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 45, in run_one_task
return fn(**kwargs)
File "/home/teuthworker/src/ceph-qa-suite_jewel/tasks/radosgw_admin.py", line 282, in task
assert out1 == out2
AssertionError

2016-08-12T08:48:23.904 ERROR:teuthology.run_tasks: Sentry event: http://sentry.ceph.com/sepia/teuthology/?q=6651bf69a8eb4559812ceb207251c090
Traceback (most recent call last):
File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 66, in run_tasks
manager = run_one_task(taskname, ctx=ctx, config=config)
File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 45, in run_one_task
return fn(**kwargs)
File "/home/teuthworker/src/ceph-qa-suite_jewel/tasks/radosgw_admin.py", line 282, in task
assert out1 == out2
AssertionError
2016-08-12T08:48:23.905 DEBUG:teuthology.run_tasks:Unwinding manager radosgw-agent


Related issues

Copied to ceph-qa-suite - Backport #17031: jewel: radosgw-admin-data-sync fails because of data_extra_pool Resolved

History

#1 Updated by Orit Wasserman almost 4 years ago

  • Status changed from New to Fix Under Review

#2 Updated by Loic Dachary almost 4 years ago

  • Status changed from Fix Under Review to Pending Backport
  • Assignee set to Orit Wasserman

#3 Updated by Loic Dachary almost 4 years ago

  • Copied to Backport #17031: jewel: radosgw-admin-data-sync fails because of data_extra_pool added

#4 Updated by Orit Wasserman almost 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF