Project

General

Profile

Actions

Cleanup #16990

closed

'rbd image-meta remove' of missing key does not return error

Added by Jason Dillaman over 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Target version:
-
% Done:

0%

Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

The command should indicate that the operation failed if the image or key doesn't exist.

Actions #1

Updated by Jason Dillaman over 7 years ago

  • Copied from Cleanup #16987: 'rbd du' of missing image does not return error added
Actions #2

Updated by Jason Dillaman over 7 years ago

  • Status changed from New to Duplicate

Duplicate of 16987

Actions #3

Updated by Jason Dillaman over 7 years ago

  • Copied from deleted (Cleanup #16987: 'rbd du' of missing image does not return error)
Actions #4

Updated by Jason Dillaman over 7 years ago

  • Status changed from Duplicate to New
  • Backport changed from jewel to kraken,jewel
Actions #5

Updated by Amit Kumar over 6 years ago

  1. rbd --version
    ceph version 12.0.0-1468-g0214e06 (0214e063056cd0ce3a80cea13087f68be8017b20)
  2. rbd image-meta remove
    rbd: image name was not specified
    2017-07-17 23:18:53.914545 7f109cf60640 -1 did not load config file, using default settings. #

//it looks it generates "image name was not specified" error

Actions #6

Updated by Jason Dillaman over 6 years ago

  • Status changed from New to In Progress
Actions #7

Updated by Jason Dillaman over 6 years ago

  • Status changed from In Progress to Resolved
  • Backport deleted (kraken,jewel)
Actions

Also available in: Atom PDF