Project

General

Profile

Bug #16882

ceph_test_librbd and ceph_test_rbd_mirror fails with cmake build

Added by Kefu Chai almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

$ ./bin/ceph_test_rbd_mirror
[==========] Running 36 tests from 5 test cases.
[----------] Global test environment set-up.
[----------] 4 tests from TestClusterWatcher
[ RUN      ] TestClusterWatcher.NoPools
[       OK ] TestClusterWatcher.NoPools (35 ms)
[ RUN      ] TestClusterWatcher.NoMirroredPools
/var/ceph/ceph/src/common/lockdep.cc: In function 'int lockdep_will_lock(const char*, int, bool)' thread 7ff6f47f8700 time 2016-08-01 19:35:45.001644
/var/ceph/ceph/src/common/lockdep.cc: 299: FAILED assert(0)
 ceph version Development (no_version)
 1: (()+0x522dee) [0x7ff71509adee]
 2: (()+0x482b35) [0x7ff714ffab35]
 3: (()+0x45ed2a) [0x7ff714fd6d2a]
 4: (()+0x4bdca2) [0x7ff715035ca2]
 5: (()+0x4be248) [0x7ff715036248]
 6: (()+0x1cbe20) [0x7ff714d43e20]
 7: (()+0x3613ae) [0x7ff714ed93ae]
 8: (()+0x35cb27) [0x7ff714ed4b27]
 9: (()+0x5c8d0a) [0x7ff715140d0a]
 10: (()+0x5d258f) [0x7ff71514a58f]
 11: (()+0x5d9b9a) [0x7ff715151b9a]
 12: (()+0x524f5d) [0x7ff71509cf5d]
 13: (()+0x524e92) [0x7ff71509ce92]
 14: (()+0x7464) [0x7ff726633464]
 15: (clone()+0x6d) [0x7ff711d4830d]
 NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.
Aborted

looks like a regression caused by 0edfad088a0e3c2949c294bdb53332a89a75a25b

History

#2 Updated by Samuel Just almost 4 years ago

lgtm

#3 Updated by Kefu Chai almost 4 years ago

  • Assignee set to Jason Dillaman

#4 Updated by Jason Dillaman almost 4 years ago

  • Status changed from New to In Progress

#5 Updated by Jason Dillaman almost 4 years ago

  • Status changed from In Progress to Fix Under Review

#6 Updated by Kefu Chai almost 4 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF