Project

General

Profile

Bug #16717

"[ FAILED ] TestLibRBD.TestCreateLsDeletePP" in upgrade:client-upgrade-jewel-distro-basic-smithi

Added by Yuri Weinstein almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
upgrade/client-upgrade
Pull request ID:
Crash signature:

Description

Run: http://pulpito.ceph.com/teuthology-2016-07-13_02:45:02-upgrade:client-upgrade-jewel-distro-basic-smithi/
Job: 312099
Logs: http://qa-proxy.ceph.com/teuthology/teuthology-2016-07-13_02:45:02-upgrade:client-upgrade-jewel-distro-basic-smithi/312099/teuthology.log

2016-07-18T02:05:05.602 INFO:tasks.workunit.client.0.smithi066.stdout:Value of: rbd.create(ioctx, name2.c_str(), size, &order)
2016-07-18T02:05:05.602 INFO:tasks.workunit.client.0.smithi066.stdout:  Actual: -38
2016-07-18T02:05:05.602 INFO:tasks.workunit.client.0.smithi066.stdout:Expected: 0
2016-07-18T02:05:05.603 INFO:tasks.workunit.client.0.smithi066.stdout:[  FAILED  ] TestLibRBD.TestCreateLsDeletePP (6106 ms)

History

#1 Updated by Mykola Golub almost 4 years ago

The teuthology suit upgrades client host from hammer to jewel and reverts ceph_test_librbd_api to hammer using this procedure:

before upgrade backup hammer ceph_test_librbd_api binary:

cp $(which ceph_test_librbd_api) $TESTDIR/ceph_test_librbd_api

after upgrade restore ceph_test_librbd_api binary:

cp --force $TESTDIR/ceph_test_librbd_api $(which ceph_test_librbd_api)

ceph_test_librbd_api is a dynamically linked binary, so the suit tests client with jewel librbd.

For TestCreateLsDeletePP case it failed because the test created the second image using rbd.create directly (instead of the wrapper that respects RBD_FEATURES env), so the jewel default features from librbd were used.

#2 Updated by Mykola Golub almost 4 years ago

I guess running hammer ceph_test_librbd_api with jewel librbd is intentional (to run only hammer tests using jewel librbd client)? In this case we need to fix TestCreateLsDeletePP to use create_image_pp() instead of rbd.create().

#3 Updated by Mykola Golub almost 4 years ago

  • Status changed from New to In Progress
  • Assignee set to Mykola Golub

#4 Updated by Mykola Golub almost 4 years ago

  • Status changed from In Progress to Fix Under Review
  • Backport set to jewel, hammer

#5 Updated by Jason Dillaman almost 4 years ago

  • Backport changed from jewel, hammer to jewel, infernalis, hammer

#6 Updated by Jason Dillaman almost 4 years ago

  • Status changed from Fix Under Review to In Progress
  • Backport deleted (jewel, infernalis, hammer)

@Mykola: instead of waiting (possibly for a very long time) for the backport, perhaps just change the test [1] to override the rbd_default_features configuration setting back to pre-Jewel.

[1] https://github.com/ceph/ceph-qa-suite/blob/master/suites/upgrade/client-upgrade/hammer-client-x/basic/2-workload/rbd_api_tests.yaml

#9 Updated by Loic Dachary almost 4 years ago

Consistently happens:

filter="upgrade:client-upgrade/hammer-client-x/basic/{0-cluster/start.yaml 1-install/hammer-client-x.yaml 2-workload/rbd_api_tests.yaml}" 
teuthology-suite --num 2 --verbose --suite-branch jewel --ceph jewel --suite upgrade/client-upgrade --filter "$filter" --machine-type vps --email loic@dachary.org --priority 50

#11 Updated by Mykola Golub almost 4 years ago

  • Status changed from In Progress to Fix Under Review

#12 Updated by Jason Dillaman almost 4 years ago

  • Status changed from Fix Under Review to Resolved

#13 Updated by Mykola Golub almost 4 years ago

  • Status changed from Resolved to Pending Backport

I think we still need to backport https://github.com/ceph/ceph-qa-suite/pull/1172 to jewel branch. AFAIR teuthology runs it with '--suite-branch jewel'.

#14 Updated by Jason Dillaman almost 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF