Project

General

Profile

Bug #16655

ceph-fuse is not linked to libtcmalloc

Added by Zheng Yan over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Performance/Resource Usage
Target version:
-
Start date:
07/12/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature:

Description

For ceph-fuse binary at http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-fuse-10.2.2-0.el7.x86_64.rpm

[root@zhyan-desk1 bin]# ldd ceph-fuse
linux-vdso.so.1 (0x00007ffdaf9a6000)
libfuse.so.2 => /usr/local/lib/libfuse.so.2 (0x00007f9ea5eeb000)
libboost_thread-mt.so.1.53.0 => not found
libboost_system-mt.so.1.53.0 => not found
libnss3.so => /lib64/libnss3.so (0x00007f9ea5bc1000)
libnspr4.so => /lib64/libnspr4.so (0x00007f9ea5982000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f9ea5763000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f9ea555f000)
librt.so.1 => /lib64/librt.so.1 (0x00007f9ea5357000)
libboost_iostreams-mt.so.1.53.0 => not found
libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007f9ea4fd4000)
libm.so.6 => /lib64/libm.so.6 (0x00007f9ea4cd2000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f9ea4aba000)
libc.so.6 => /lib64/libc.so.6 (0x00007f9ea46f9000)
/lib64/ld-linux-x86-64.so.2 (0x0000559fed8ab000)
libnssutil3.so => /lib64/libnssutil3.so (0x00007f9ea44cb000)
libplc4.so => /lib64/libplc4.so (0x00007f9ea42c5000)
libplds4.so => /lib64/libplds4.so (0x00007f9ea40c1000)


Related issues

Copied to fs - Backport #16697: jewel: ceph-fuse is not linked to libtcmalloc Resolved

History

#1 Updated by Greg Farnum over 3 years ago

  • Priority changed from Normal to High

#2 Updated by Kefu Chai over 3 years ago

  • Status changed from New to Need Review
  • Assignee set to Zheng Yan

#4 Updated by Greg Farnum over 3 years ago

I'm a little confused about the cause here. Ken says

confirmed that /usr/bin/ceph-fuse is linked to libtcmalloc.so.4 in master, ceph-fuse-11.0.0-506.ge1f96e2.x86_64.rpm

Apparently we're not in v10.2.2.

But the fix is on top of master, which should already work? When the problem was identified, I assumed this was a one-release, or perhaps a CentOS-only build process, bug. Can anybody clarify? :)

#5 Updated by Ken Dreyer over 3 years ago

The link is definitely missing in v10.2.2.

$ cd /tmp/ceph-fuse/
$ wget http://download.ceph.com/rpm-jewel/el7/x86_64/ceph-fuse-10.2.2-0.el7.x86_64.rpm
$ rpm2cpio ceph-fuse-10.2.2-0.el7.x86_64.rpm | cpio -dium
$ ldd usr/bin/ceph-fuse | grep tcmalloc

#6 Updated by Nathan Cutler over 3 years ago

  • Backport set to jewel

#7 Updated by Nathan Cutler over 3 years ago

Greg Farnum wrote:

But the fix is on top of master, which should already work?

It looks like the bug is in the autotools stuff only. Possibly the bug exists in master (autotools) but is not showing in master because it's built with cmake. But we can merge it to master and backport to jewel to fix the bug.

#8 Updated by Greg Farnum over 3 years ago

Okay, I guess it was just introduced in some autotools refactor or update then. Thanks!

#9 Updated by Kefu Chai over 3 years ago

  • Status changed from Need Review to Pending Backport

#10 Updated by Ken Dreyer over 3 years ago

tcmalloc is also missing from ldd /usr/bin/ceph-fuse in ceph-fuse-0.94.7-0.el7, FYI, so this has gone on for quite a while.

#12 Updated by Nathan Cutler over 3 years ago

  • Copied to Backport #16697: jewel: ceph-fuse is not linked to libtcmalloc added

#13 Updated by Greg Farnum over 3 years ago

  • Category set to Performance/Resource Usage

#14 Updated by Loic Dachary about 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF