Project

General

Profile

Bug #16618

multidelete query parameter not correctly parsed

Added by Robin Johnson about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
07/07/2016
Due date:
% Done:

0%

Source:
other
Tags:
rgw, multi-delete
Backport:
hammer, jewel
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Per:
http://docs.aws.amazon.com/AmazonS3/latest/API/multiobjectdeleteapi.html

Look very closely at the query parameters in the URI.
The API says "delete" with no value.

Boto sends the same "delete"
Ruby aws-sdk-v1 sends "delete=" (no value, but explicit "=")

Ceph looks for EXACTLY "delete" as the query parameter.
https://github.com/ceph/ceph/blob/master/src/rgw/rgw_rest_s3.cc#L2864

I think Ceph should be less strict, so that the Ruby aws-sdk-v1 Gem works.

This bug has been present since multi-delete was first introduced in commit 0a1f4a97dab02d951834882985523657dfea7e09, v0.50-158-g0a1f4a9 for bobtail.


Related issues

Copied to rgw - Backport #16698: hammer: multidelete query parameter not correctly parsed Resolved
Copied to rgw - Backport #16699: jewel: multidelete query parameter not correctly parsed Resolved

History

#1 Updated by Robin Johnson about 3 years ago

Fix for review & merging in https://github.com/ceph/ceph/pull/10187

#3 Updated by Nathan Cutler about 3 years ago

  • Status changed from New to Need Review

#4 Updated by Yehuda Sadeh about 3 years ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler about 3 years ago

  • Copied to Backport #16698: hammer: multidelete query parameter not correctly parsed added

#6 Updated by Nathan Cutler about 3 years ago

  • Copied to Backport #16699: jewel: multidelete query parameter not correctly parsed added

#7 Updated by Loic Dachary about 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF