Project

General

Profile

Bug #16611

build/ops: issue while building against libxfs

Added by Gaurav Garg over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
build
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Without -D_LARGEFILE64_SOURCE we can't build against libxfs,
because off64_t must be defined.


Related issues

Copied to Ceph - Backport #16612: hammer: build/ops: issue while building against libxfs Resolved

History

#1 Updated by Gaurav Garg over 6 years ago

upstream PR already merged https://github.com/ceph/ceph/pull/8402

backport pending for hammer release.

#2 Updated by Abhishek Lekshmanan over 6 years ago

  • Copied to Backport #16612: hammer: build/ops: issue while building against libxfs added

#3 Updated by Nathan Cutler over 6 years ago

  • Status changed from New to Pending Backport
  • Backport set to hammer

#4 Updated by Nathan Cutler over 6 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF