Project

General

Profile

Bug #16609

clog_to_syslog logs messages without process identification

Added by Gerben Meijer over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
jewel, hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

When turning on clog_to_syslog, messages from at least MON and OSD are logged with 'unknown.0':

Jul  7 04:10:01 ceph1 ceph-osd: unknown.0 :/0 0 : slow request -REDACTED- currently waiting for rw locks
Jul  6 09:44:16 mon1 ceph-mon: unknown.0 :/0 0 : pgmap -REDACTED- recovering

That isn't too much of a problem with mons where there's just one mon per host, but it's a problem for OSDs where this causes messages to be unidentifyable.

This is happening in Hammer 0.94.7 and probably newer too but have not confirmed yet.

My current guess is that this was introduced in https://github.com/ceph/ceph/commit/7ef1273a519636aa008e84d828ad90d5cdaf5d46:

-  e.who = messenger->get_myinst();
+  // who will be set when we queue the entry on LogClient
+  //e.who = messenger->get_myinst();

Because a few lines further down, we see:

+  if (do_log_to_syslog()) {
+    ldout(cct,0) << __func__ << " log to syslog"  << dendl;
+    e.log_to_syslog(get_log_prio(), get_syslog_facility());
    }

And since e.who isn't set here, we may be getting unknown.0?

History

#1 Updated by Xiaoxi Chen over 6 years ago

  • Status changed from New to Fix Under Review

#2 Updated by Kefu Chai over 6 years ago

  • Assignee set to Xiaoxi Chen
  • Backport set to jewel, hammer

#3 Updated by Kefu Chai about 6 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF