Project

General

Profile

Bug #16404

Sporadic test failures when image update notification missed

Added by Jason Dillaman about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
06/21/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Hammer and Infernalis automatically mark the image as updated when proxying requests to the exclusive lock holder to cover the case where the update notification is lost due to an overloaded OSD. During Jewel refactoring, this backstop feature was dropped and results in sporadic test failures when the OSDs are thrashed.


Related issues

Copied to rbd - Backport #16422: jewel: Sporadic test failures when image update notification missed Resolved

History

#1 Updated by Jason Dillaman about 3 years ago

  • Status changed from Feedback to In Progress

#2 Updated by Jason Dillaman about 3 years ago

  • Status changed from In Progress to Need Review

#3 Updated by Mykola Golub about 3 years ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Nathan Cutler about 3 years ago

  • Copied to Backport #16422: jewel: Sporadic test failures when image update notification missed added

#5 Updated by Loic Dachary about 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF