Project

General

Profile

Bug #16399

ceph-deploy requires python-distribute

Added by Ed Byrne about 3 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
-
Target version:
-
Start date:
06/21/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
ceph-deploy

Description

CentOS 7's openstack-mitaka repo recently introduced python2-setuptools-22.0.5-1.el7.noarch.rpm. This package comes from upstream Fedora and no longer provides python-distribute, which causes dependency issues with ceph-deploy in ceph.com's Jewel repo. According to http://stackoverflow.com/a/14753678, python-distribute was merged back into python-setuptools, so there should be no reason to require both.

I was able to remove the Requires and BuildRequires lines from the spec file in ceph-deploy-1.5.33-0.src.rpm and it built fine, and from minimal testing appears to operate fine without it.

ceph-deploy.spec.patch View (616 Bytes) Ed Byrne, 06/21/2016 03:09 PM

History

#1 Updated by Ed Byrne about 3 years ago

The patch also applies to ceph-deploy-1.5.34-0.src.rpm just fine.

#2 Updated by Nathan Cutler about 3 years ago

  • Project changed from Ceph to Ceph-deploy

#3 Updated by Gaurav Goyal about 3 years ago

hi Guys,

I have faced same issue while installing ceph-deploy. May i know how to apply this patch in order to move further?
I am still stuck up here.

Regards
Gaurav Goyal

#4 Updated by Tyler Bishop almost 3 years ago

This is still impacting all systems utilizing rpm versions of ceph-deploy.

#5 Updated by Dmitry Smirnov about 2 years ago

Still problems, trying to upgrade to v12.2 I've faced same issue.

  1. yum update ceph-deploy
    Loaded plugins: langpacks, priorities, product-id, search-disabled-repos, subscription-manager
    This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
    53 packages excluded due to repository priority protections
    Resolving Dependencies
    --> Running transaction check
    ---> Package ceph-deploy.noarch 0:1.5.37-0 will be updated
    ---> Package ceph-deploy.noarch 0:1.5.38-0 will be an update
    --> Processing Dependency: python-distribute for package: ceph-deploy-1.5.38-0.noarch
    --> Running transaction check
    ---> Package python-setuptools.noarch 0:0.9.8-4.el7 will be installed
    Removing python-setuptools.noarch 0:0.9.8-4.el7 - u due to obsoletes from installed python2-setuptools-22.0.5-1.el7.noarch
    --> Restarting Dependency Resolution with new changes.
    --> Running transaction check
    ---> Package python-setuptools.noarch 0:0.9.8-4.el7 will be installed
    --> Processing Dependency: python-distribute for package: ceph-deploy-1.5.38-0.noarch
    --> Running transaction check
    ---> Package python-setuptools.noarch 0:0.9.8-3.el7 will be installed
    Removing python-setuptools.noarch 0:0.9.8-3.el7 - u due to obsoletes from installed python2-setuptools-22.0.5-1.el7.noarch
    --> Restarting Dependency Resolution with new changes.
    --> Running transaction check
    ---> Package python-setuptools.noarch 0:0.9.8-3.el7 will be installed
    --> Processing Dependency: python-distribute for package: ceph-deploy-1.5.38-0.noarch
    --> Finished Dependency Resolution
    Error: Package: ceph-deploy-1.5.38-0.noarch (ceph-noarch)
    Requires: python-distribute
    You could try using --skip-broken to work around the problem
    • Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
      ceph-deploy-1.5.37-0.noarch has missing requires of python-distribute

OpenStack Newton is installed on all CEPH nodes.

#6 Updated by Vasu Kulkarni about 2 years ago

Dmitry Smirnov wrote:

Still problems, trying to upgrade to v12.2 I've faced same issue.

as a workaround you can try to install the pip package and move on, 'pip install ceph-deploy', I will use the patch submitted in original post and send it for review.

#7 Updated by Vasu Kulkarni about 2 years ago

  • Priority changed from Normal to High

#8 Updated by Vasu Kulkarni about 2 years ago

  • Status changed from New to Need Review

#9 Updated by Dmitry Smirnov almost 2 years ago

Solved that way:

1) wget http://download.ceph.com/rpm-luminous/el7/noarch/ceph-deploy-1.5.39-0.noarch.rpm
2) rpm -Uvh ceph-deploy-1.5.39-0.noarch.rpm --nodeps

#10 Updated by Alfredo Deza over 1 year ago

  • Status changed from Need Review to Resolved

This has been fixed for 2.0.0 and released in the latest ceph luminous (12.2.3)

Also available in: Atom PDF