Project

General

Profile

Bug #16364

Crash when utilizing advisory locking API functions

Added by Jason Dillaman about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

The advisory locking functions permit the image to be opened in R/O mode but also send header update notifications. Since the image is in R/O mode, the ImageWatcher wasn't initialized and cannot be used for sending update notifications. Re-introduce the static update notification helper method and use it for the advisory locking functions.


Related issues

Copied to rbd - Backport #16460: jewel: Crash when utilizing advisory locking API functions Resolved

History

#1 Updated by Jason Dillaman about 4 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#2 Updated by Jason Dillaman about 4 years ago

  • Status changed from In Progress to Fix Under Review

#3 Updated by Mykola Golub about 4 years ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Nathan Cutler about 4 years ago

  • Copied to Backport #16460: jewel: Crash when utilizing advisory locking API functions added

#5 Updated by Loic Dachary almost 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF