Project

General

Profile

Bug #16287

./common/hobject.h: 182: FAILED assert(!max || (*this == hobject_t(hobject_t::get_max())))

Added by Sage Weil about 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

/a/sage-2016-06-13_06:57:15-rados-wip-sage-testing---basic-smithi/256206

     0> 2016-06-14 00:03:27.584783 7f4127acb700 -1 ./common/hobject.h: In function 'bool hobject_t::is_max() const' thread 7f4127acb700 time 2016-06-14 00:03:27.582076
./common/hobject.h: 182: FAILED assert(!max || (*this == hobject_t(hobject_t::get_max())))

 ceph version 10.2.0-2221-ge6c2ee0 (e6c2ee0958e18f048f9ba97a96aa1cb5b528a7ec)
 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x8b) [0x7f413c58144b]
 2: (hobject_t::is_max() const+0x9e) [0x7f413bf1404e]
 3: (PG::choose_acting(pg_shard_t&, bool*)+0x96c) [0x7f413bf9843c]
 4: (PG::RecoveryState::GetLog::GetLog(boost::statechart::state<PG::RecoveryState::GetLog, PG::RecoveryState::Peering, boost::mpl::list<mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, 
mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na>, (boost::statechart::history_mode)0>
::my_context)+0x159) [0x7f413bfa73d9]
 5: (boost::statechart::detail::safe_reaction_result boost::statechart::simple_state<PG::RecoveryState::GetInfo, PG::RecoveryState::Peering, boost::mpl::list<mpl_::na, mpl_::na, mpl_::na
, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na>, (boost::state
chart::history_mode)0>::transit_impl<PG::RecoveryState::GetLog, PG::RecoveryState::RecoveryMachine, boost::statechart::detail::no_transition_function>(boost::statechart::detail::no_trans
ition_function const&)+0xb8) [0x7f413bff29e8]
 6: (boost::statechart::simple_state<PG::RecoveryState::GetInfo, PG::RecoveryState::Peering, boost::mpl::list<mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::
na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na>, (boost::statechart::history_mode)0>::react_impl(boost::statec
hart::event_base const&, void const*)+0x13a) [0x7f413bff2d1a]
 7: (boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>::send_event(boos
t::statechart::event_base const&)+0x5b) [0x7f413bfdaefb]
 8: (boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>::process_queued_
events()+0xd8) [0x7f413bfdb068]
 9: (PG::handle_peering_event(std::shared_ptr<PG::CephPeeringEvt>, PG::RecoveryCtx*)+0x1e6) [0x7f413bfa3a56]
 10: (OSD::process_peering_events(std::list<PG*, std::allocator<PG*> > const&, ThreadPool::TPHandle&)+0x267) [0x7f413beffa87]
 11: (OSD::PeeringWQ::_process(std::list<PG*, std::allocator<PG*> > const&, ThreadPool::TPHandle&)+0x12) [0x7f413bf48f52]

Related issues

Duplicates Ceph - Bug #13967: PG::choose_acting valgrind error or ./common/hobject.h: 182: FAILED assert(!max || (*this == hobject_t(hobject_t::get_max()))) Resolved 12/03/2015

History

#1 Updated by Samuel Just about 4 years ago

  • Duplicates Bug #14693: osd: valgrind uninitcondition in PG::choose_acting(pg_shard_t&) added

#2 Updated by Samuel Just about 4 years ago

  • Status changed from New to Duplicate

Hah, this is a dup of http://tracker.ceph.com/issues/14693. The all_info.find() returns an invalid iterator when up_primary isn't valid. The kicker is that that whole block seems to be unnecessary: https://github.com/ceph/ceph/pull/8370!

#3 Updated by Samuel Just about 4 years ago

  • Duplicates deleted (Bug #14693: osd: valgrind uninitcondition in PG::choose_acting(pg_shard_t&))

#4 Updated by Samuel Just about 4 years ago

  • Duplicates Bug #13967: PG::choose_acting valgrind error or ./common/hobject.h: 182: FAILED assert(!max || (*this == hobject_t(hobject_t::get_max()))) added

#5 Updated by Samuel Just about 4 years ago

Oops, that one's a dup as well, switched the link.

Also available in: Atom PDF