Project

General

Profile

Bug #16030

concurrent.sh coredumps

Added by Ilya Dryomov about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
rbd
Target version:
-
Start date:
05/25/2016
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:


Related issues

Duplicated by Linux kernel client - Bug #15735: core dump during krbd concurrent.sh Duplicate 05/04/2016

Associated revisions

Revision 4be8a28d (diff)
Added by Sage Weil almost 4 years ago

osd/PG: peek_map_epoch: skip legacy PGs if infos object is missing

- pg is removed
- osd is stopped before pg is fully removed
- on restart, we ignore/skip the pg because its epoch is too old
- we upgrade to hammer and convert other pgs, skipping this one, and then
remove the legacy infos object
- hammer starts, tries to parse the legacy pg, and fails because the infos
object is gone, crashing.

The fix is to continue ignoring the zombie pg.

Fixes: #16030
Signed-off-by: Sage Weil <>

History

#1 Updated by Ilya Dryomov about 3 years ago

  • Status changed from Verified to In Progress

#2 Updated by Ilya Dryomov about 3 years ago

  • Status changed from In Progress to Need Review

#3 Updated by Ilya Dryomov about 3 years ago

  • Status changed from Need Review to Resolved

#4 Updated by Ilya Dryomov about 3 years ago

  • Duplicated by Bug #15735: core dump during krbd concurrent.sh added

Also available in: Atom PDF