Project

General

Profile

Bug #15974

MethodNotAllowed when RGWs APIs customized

Added by Robin Johnson about 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

From IRC discussion between Robin & Yehuda.

If rgw_enable_apis is customized, such as for staticsites, you can end up getting a NULL RESTManager.


Related issues

Duplicates rgw - Bug #15973: rgw: can't use only the s3 api Resolved 05/20/2016

History

#2 Updated by Robin Johnson about 5 years ago

  • Status changed from Fix Under Review to Duplicate

Duplicate of #15973

#3 Updated by Nathan Cutler almost 5 years ago

  • Target version deleted (v10.2.2)

#4 Updated by Nathan Cutler almost 5 years ago

  • Duplicates Bug #15973: rgw: can't use only the s3 api added

Also available in: Atom PDF