Project

General

Profile

Bug #15686

reweight-by-utilization:- While increasing the weight of the underutilized osds we should consider the least used first

Added by Shylesh Kumar over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
jewel, hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

reweight-by-utilization command along with the decreasing the overutilized osds it will also increase the weight of underutilized, But while choosing the underutilized there is a small glitch reweight-by-utilization works on a sorted list from higher to lower utilized osds.

for ex assume utilization list looks like [0.80, 0.75,0.71, 0.60, 0.55,0.45,0.30] and assume avg_utilization=0.60 and max_osd=4. Now assume there are 2 osds which satisfy oload values and it will be picked for decreasing the weight, since max_osd is 4 we can choose 2 more osds for increasing the weight.

While walking in this list first osd with utilization of 0.55(which is less than 0.60) will be considered as underutilized and thereby its weight will be increased. Instead we can pick the osd with 0.30 utilization since its the most underutilized osd.


Related issues

Copied to Ceph - Backport #15769: jewel: reweight-by-utilization:- While increasing the weight of the underutilized osds we should consider the least used first Resolved
Copied to Ceph - Backport #15770: hammer: reweight-by-utilization:- While increasing the weight of the underutilized osds we should consider the least used first Resolved

History

#1 Updated by Samuel Just over 5 years ago

  • Priority changed from Normal to Urgent

#2 Updated by Samuel Just over 5 years ago

  • Status changed from New to Fix Under Review

#4 Updated by Ken Dreyer over 5 years ago

  • Backport set to jewel

#5 Updated by Ken Dreyer over 5 years ago

  • Subject changed from [RADOS-Reweight-by-utilizatoin]:- While increasing the weight of the underutilized osds we should consider the least used first to reweight-by-utilization:- While increasing the weight of the underutilized osds we should consider the least used first
  • Status changed from Fix Under Review to Pending Backport
  • Backport changed from jewel to jewel, hammer

Needs a backport to jewel and hammer at least (I don't care about infernalis)

#6 Updated by Nathan Cutler over 5 years ago

  • Copied to Backport #15769: jewel: reweight-by-utilization:- While increasing the weight of the underutilized osds we should consider the least used first added

#7 Updated by Nathan Cutler over 5 years ago

  • Copied to Backport #15770: hammer: reweight-by-utilization:- While increasing the weight of the underutilized osds we should consider the least used first added

#8 Updated by Nathan Cutler about 5 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF