Project

General

Profile

Bug #15546

json numerical output is between quotes

Added by Kenneth Waegeman almost 7 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Administration/Usability
Target version:
-
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Monitor, ceph cli
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

eg. rados df --format json {"pools":[{"name":"cache","id":"4","size_bytes":"654457325949","size_kb":"639118483","num_objects":"379236","num_object_clones":"0","num_object_copies":"1137708","num_objects_missing_on_primary":"0","num_objects_unfound":"0","num_objects_degraded":"0","read_ops":"4509188","read_bytes":"771548416000","write_ops":"1988817863","write_bytes":"445934781936640"},{"name":"ecdata","id":"5","size_bytes":"281423075934690","size_kb":"274827222593","num_objects":"155674545","num_object_clones":"0","num_object_copies":"1712419995","num_objects_missing_on_primary":"0","num_objects_unfound":"0","num_objects_degraded":"0","read_ops":"6213840","read_bytes":"395244460032","write_ops":"358867414","write_bytes":"448559142914048"},{"name":"metadata","id":"6","size_bytes":"48836022","size_kb":"47692","num_objects":"6617242","num_object_clones":"0","num_object_copies":"19851726","num_objects_missing_on_primary":"0","num_objects_unfound":"0","num_objects_degraded":"0","read_ops":"110569347","read_bytes":"3116419604480","write_ops":"196497502","write_bytes":"5373589568512"},{"name":"rbd","id":"0","size_bytes":"0","size_kb":"0","num_objects":"3","num_object_clones":"0","num_object_copies":"9","num_objects_missing_on_primary":"0","num_objects_unfound":"0","num_objects_degraded":"0","read_ops":"0","read_bytes":"0","write_ops":"12","write_bytes":"0"}],"total_objects":"162671026","total_used":"386856566500","total_avail":"551704147448","total_space":"938560713948"}[

All these numbers shouldn't be in quotes, eg. for elasticsearch

History

#1 Updated by Greg Farnum over 5 years ago

  • Project changed from Ceph to RADOS
  • Category set to Administration/Usability
  • Component(RADOS) Monitor, ceph cli added

#2 Updated by Laura Flores over 1 year ago

This seems to be okay now. Is it possible that this issue was fixed without getting updated?

./bin/rados df --format json

{"pools":[{"name":".mgr","id":1,"size_bytes":1388544,"size_kb":1356,"num_objects":2,"num_object_clones":0,"num_object_copies":6,"num_objects_missing_on_primary":0,"num_objects_unfound":0,"num_objects_degraded":0,"read_ops":60,"read_bytes":52224,"write_ops":71,"write_bytes":877568,"compress_bytes_used":0,"compress_under_bytes":0},{"name":".rgw.root","id":4,"size_bytes":49152,"size_kb":48,"num_objects":6,"num_object_clones":0,"num_object_copies":18,"num_objects_missing_on_primary":0,"num_objects_unfound":0,"num_objects_degraded":0,"read_ops":6,"read_bytes":6144,"write_ops":4,"write_bytes":4096,"compress_bytes_used":0,"compress_under_bytes":0},{"name":"cephfs.a.data","id":3,"size_bytes":0,"size_kb":0,"num_objects":0,"num_object_clones":0,"num_object_copies":0,"num_objects_missing_on_primary":0,"num_objects_unfound":0,"num_objects_degraded":0,"read_ops":0,"read_bytes":0,"write_ops":0,"write_bytes":0,"compress_bytes_used":0,"compress_under_bytes":0},{"name":"cephfs.a.meta","id":2,"size_bytes":98304,"size_kb":96,"num_objects":23,"num_object_clones":0,"num_object_copies":69,"num_objects_missing_on_primary":0,"num_objects_unfound":0,"num_objects_degraded":0,"read_ops":0,"read_bytes":0,"write_ops":30,"write_bytes":9216,"compress_bytes_used":0,"compress_under_bytes":0},{"name":"default.rgw.control","id":6,"size_bytes":0,"size_kb":0,"num_objects":6,"num_object_clones":0,"num_object_copies":18,"num_objects_missing_on_primary":0,"num_objects_unfound":0,"num_objects_degraded":0,"read_ops":0,"read_bytes":0,"write_ops":0,"write_bytes":0,"compress_bytes_used":0,"compress_under_bytes":0},{"name":"default.rgw.log","id":5,"size_bytes":417792,"size_kb":408,"num_objects":176,"num_object_clones":0,"num_object_copies":528,"num_objects_missing_on_primary":0,"num_objects_unfound":0,"num_objects_degraded":0,"read_ops":1244,"read_bytes":1043456,"write_ops":720,"write_bytes":32768,"compress_bytes_used":0,"compress_under_bytes":0},{"name":"default.rgw.meta","id":7,"size_bytes":172032,"size_kb":168,"num_objects":14,"num_object_clones":0,"num_object_copies":42,"num_objects_missing_on_primary":0,"num_objects_unfound":0,"num_objects_degraded":0,"read_ops":0,"read_bytes":0,"write_ops":22,"write_bytes":15360,"compress_bytes_used":0,"compress_under_bytes":0}],"total_objects":227,"total_used":3150528,"total_avail":314567976,"total_space":317718504}

#3 Updated by Neha Ojha over 1 year ago

  • Status changed from New to Resolved

Also available in: Atom PDF