Project

General

Profile

Bug #1554

rbd rollback does not work with a snapshot of an empty image

Added by Josh Durgin over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Found this when testing python bindings for librbd. If you
1. create an rbd image
2. create a snapshot
3. write to the image
4. rollback to the snapshot

When you read the image again, you'll get the newly written data instead of zeroes, which is what the image contained when you snapshotted it.

Associated revisions

Revision 12ce321b (diff)
Added by Josh Durgin over 9 years ago

ReplicatedPG: reset return code after find_object_context

This way the object is actually deleted when it has no snapshots,
since the transaction is not aborted. This makes
test_rbd:TestImage.test_rollback_to_snap_sparse pass.

Fixes: #1554
Signed-off-by: Josh Durgin <>

History

#1 Updated by Sage Weil over 9 years ago

  • translation missing: en.field_position set to 896

#2 Updated by Sage Weil over 9 years ago

  • translation missing: en.field_position deleted (899)
  • translation missing: en.field_position set to 42

#3 Updated by Josh Durgin over 9 years ago

  • Assignee set to Josh Durgin

#4 Updated by Josh Durgin over 9 years ago

  • Category changed from librbd to OSD
  • Status changed from New to Resolved

Also available in: Atom PDF