Project

General

Profile

Actions

Bug #15521

closed

Seeing rollback and revert option for snapshot, which seems to be same and can be confusing for users

Added by Tanay Ganguly almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Description of problem:
Seeing rollback and revert option for snapshot, which seems to be same

Version-Release number of selected component (if applicable):
10.1.1.1

How reproducible:
NA

[root@cephqe6 ~]# rbd help snap rollback
usage: rbd snap rollback [--pool <pool>] [--image <image>] [--snap <snap>]
[--no-progress]
<snap-spec>

Rollback image to snapshot.
Positional arguments
&lt;snap-spec&gt; snapshot specification
(example: [&lt;pool-name&gt;/]&lt;image-name&gt;@&lt;snapshot-name&gt;)
Optional arguments
-p [ --pool ] arg pool name
--image arg image name
--snap arg snapshot name
--no-progress disable progress output

[root@cephqe6 ~]# rbd help snap revert
usage: rbd snap rollback [--pool <pool>] [--image <image>] [--snap <snap>]
[--no-progress]
<snap-spec>

Rollback image to snapshot.
Positional arguments
&lt;snap-spec&gt; snapshot specification
(example: [&lt;pool-name&gt;/]&lt;image-name&gt;@&lt;snapshot-name&gt;)
Optional arguments
-p [ --pool ] arg pool name
--image arg image name
--snap arg snapshot name
--no-progress disable progress output

Related issues 1 (0 open1 closed)

Copied to rbd - Backport #15708: jewel: Seeing rollback and revert option for snapshot, which seems to be same and can be confusing for usersResolvedJason DillamanActions
Actions #1

Updated by Jason Dillaman almost 8 years ago

  • Backport set to jewel
Actions #2

Updated by Jason Dillaman almost 8 years ago

  • Status changed from New to Fix Under Review
Actions #3

Updated by Jason Dillaman almost 8 years ago

  • Status changed from Fix Under Review to Pending Backport
Actions #4

Updated by Nathan Cutler almost 8 years ago

  • Copied to Backport #15708: jewel: Seeing rollback and revert option for snapshot, which seems to be same and can be confusing for users added
Actions #5

Updated by Jason Dillaman almost 8 years ago

  • Status changed from Pending Backport to Resolved
Actions

Also available in: Atom PDF