Project

General

Profile

Backport #15478

hammer: Pool quota alarm is not in effect

Added by huanwen ren about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Release:
hammer
Crash signature (v1):
Crash signature (v2):

History

#2 Updated by Kefu Chai about 6 years ago

  • Tracker changed from Bug to Backport
  • Status changed from New to Fix Under Review

#3 Updated by Kefu Chai about 6 years ago

  • Status changed from Fix Under Review to In Progress

#4 Updated by Kefu Chai about 6 years ago

  • Assignee set to huanwen ren
  • Target version set to v0.94.7

#5 Updated by Nathan Cutler about 6 years ago

This is a partial backport of https://github.com/ceph/ceph/pull/5000 which had no corresponding tracker issue.

#6 Updated by huanwen ren about 6 years ago

close:https://github.com/ceph/ceph/pull/8571
updated to:https://github.com/ceph/ceph/pull/8593

#8 Updated by Nathan Cutler about 6 years ago

  • Description updated (diff)
  • Target version deleted (v0.94.7)

Original description

step1:
I set quoat'alarm/crit for the pool in the ceph.conf
mon_pool_quota_warn_threshold = 50
mon_pool_quota_crit_threshold = 90

step2:
create pool

step3:
set the quota of pool

step4:
copying data to the pool(state of alarm or crit)
At the same time confirmed that the quota has to take effect

step5:
used "ceph health detail" command to test, found no quota warn/crit!!!

the reason:

void OSDMonitor::get_pools_health(
    list<pair<health_status_t,string> >& summary,
    list<pair<health_status_t,string> > *detail) const
{
  ......
  float warn_threshold = g_conf->mon_pool_quota_warn_threshold/100;
  float crit_threshold = g_conf->mon_pool_quota_crit_threshold/100;
  ......
}
"warn_threshold or crit_threshold"  has been equal to zero, when g_conf->mon_pool_quota_crit_threshold or g_conf->mon_pool_quota_crit_threshold is less than 100

In fact:
g_conf->mon_pool_quota_crit_threshold <= 100
g_conf->mon_pool_quota_crit_threshold <= 100

#9 Updated by Loïc Dachary about 6 years ago

  • Subject changed from Pool quota alarm is not in effect to hammer: Pool quota alarm is not in effect

#10 Updated by Loïc Dachary almost 6 years ago

  • Status changed from In Progress to Resolved
  • Target version set to v0.94.8

Also available in: Atom PDF