Project

General

Profile

Bug #15318

rgw: fails to delete keys with two underscores

Added by Orit Wasserman over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Immediate
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
Yes
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Create a bucket with keys:"_ " and "_"

delete the keys, after the delete the keys still exist and you cannot delete the bucket

History

#1 Updated by Orit Wasserman over 6 years ago

it look like we get -ENOENT when try to remove the object:
<cls> ceph/src/cls/rgw/cls_rgw.cc:2009: ERROR: rgw_obj_remove(): cls_cxx_remove returned -2

#2 Updated by Orit Wasserman over 6 years ago

  • Regression changed from No to Yes

#3 Updated by Sage Weil over 6 years ago

  • Priority changed from High to Urgent

#4 Updated by Sage Weil over 6 years ago

  • Priority changed from Urgent to Immediate

#5 Updated by Nathan Cutler over 6 years ago

Does this bug exist in hammer as well? If so, maybe worth backporting.

#6 Updated by Orit Wasserman over 6 years ago

I could not reproduce it in hammer so no need to backport

#7 Updated by Robin Johnson over 6 years ago

  • Release set to jewel

#9 Updated by Orit Wasserman over 6 years ago

  • Status changed from New to Fix Under Review
  • Affected Versions sprint added

#10 Updated by Orit Wasserman over 6 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF