Project

General

Profile

Bug #15309

Error: Creation of multiple filesystems is disabled. To enable this experimental feature, use 'ceph fs flag set enable_multiple true' (-22)

Added by Samuel Just over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2016-03-28T14:22:24.439 INFO:tasks.rest_api.client.rest0.smithi037.stderr:127.0.0.1 - - [28/Mar/2016 21:22:24] "PUT /api/v0.1/osd/pool/create?pg_num=1&pool=fsmetadata HTTP/1.1" 200 -
2016-03-28T14:22:25.709 INFO:tasks.rest_api.client.rest0.smithi037.stderr:127.0.0.1 - - [28/Mar/2016 21:22:25] "PUT /api/v0.1/osd/pool/create?pg_num=1&pool=fsdata HTTP/1.1" 200 -
2016-03-28T14:22:25.878 INFO:tasks.rest_api.client.rest0.smithi037.stderr:127.0.0.1 - - [28/Mar/2016 21:22:25] "PUT /api/v0.1/fs/new?fs_name=default&metadata=fsmetadata&data=fsdata HTTP/1.1" 400 -
2016-03-28T14:22:25.879 INFO:tasks.workunit.client.0.smithi037.stderr:FAILURE: url http://localhost:5000/api/v0.1/fs/new?fs_name=default&metadata=fsmetadata&data=fsdata
2016-03-28T14:22:25.879 INFO:tasks.workunit.client.0.smithi037.stderr:expected 200, got 400
2016-03-28T14:22:25.880 INFO:tasks.workunit.client.0.smithi037.stderr:Response content:
2016-03-28T14:22:25.880 INFO:tasks.workunit.client.0.smithi037.stderr:Error: Creation of multiple filesystems is disabled. To enable this experimental feature, use 'ceph fs flag set enable_multiple true' (-22)
2016-03-28T14:22:25.880 INFO:tasks.workunit.client.0.smithi037.stderr:
2016-03-28T14:22:25.881 INFO:tasks.workunit.client.0.smithi037.stderr:Headers: CaseInsensitiveDict({'date': 'Mon, 28 Mar 2016 21:22:25 GMT', 'content-length': '142', 'content-type': 'text/html; charset=utf-8', 'server': 'Werkzeug/0.9.4 Python/2.7.6'})

sjust@teuthology:/a/samuelj-2016-03-28_12:45:42-rados-wip-sam-testing-distro-basic-smithi/91980

History

#1 Updated by John Spray over 6 years ago

Could be failing because default pool names changed, so this looks like a "create second" rather than "it already exists, be idempotent" case. Checking...

#2 Updated by John Spray over 6 years ago

  • Status changed from New to Fix Under Review

#3 Updated by Greg Farnum over 6 years ago

  • Status changed from Fix Under Review to 7

#4 Updated by Sage Weil over 6 years ago

first bit passes, but now it fails a bit further on:

2016-03-30T15:06:45.122 INFO:tasks.workunit.client.0.smithi042.stderr:Traceback (most recent call last):
2016-03-30T15:06:45.122 INFO:tasks.workunit.client.0.smithi042.stderr: File "/home/ubuntu/cephtest/workunit.client.0/rest/test.py", line 199, in
2016-03-30T15:06:45.122 INFO:tasks.workunit.client.0.smithi042.stderr: assert('info' in r.myjson['output']['mdsmap'])
2016-03-30T15:06:45.122 INFO:tasks.workunit.client.0.smithi042.stderr:KeyError: 'mdsmap'

from http://pulpito.ceph.com/sage-2016-03-30_13:23:09-rados-wip-sage-testing-distro-basic-smithi/98173

#5 Updated by John Spray over 6 years ago

  • Status changed from 7 to Fix Under Review

#6 Updated by Zheng Yan over 6 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF