Project

General

Profile

Bug #15304

qa: samba tests need to run on testing kernel

Added by Greg Farnum over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Testing
Target version:
-
Start date:
03/29/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

I think some of our "random" samba failures are not so random. It looks like we no longer pass on any of our kclient mount tests, and when I look through the logs, they're actually getting an IO error on mount!

This actually makes some sense: the default kernels we're using (at least on ubuntu) are too old to mount a default-config CephFS any more (wrong tunables). We could configure the cluster to use old tunables, but since the whole point is to test Samba-on-CephFS, I think we want to run it against a testing kernel.

History

#1 Updated by Zheng Yan over 3 years ago

  • Status changed from New to Need Review

#2 Updated by John Spray over 3 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF