Bug #15139

fail to install firefly ceph-radosgw

Added by Sage Weil almost 4 years ago. Updated over 2 years ago.

Won't Fix
Target version:
% Done:


3 - minor
Affected Versions:
Crash signature:


2016-03-14T14:41:29.385> Finished Dependency Resolution
2016-03-14T14:41:29.496 Package: ceph-common-0.80.8-0.el7.x86_64 (Ceph)
2016-03-14T14:41:29.496           Requires: librbd1 = 0.80.8-0.el7
2016-03-14T14:41:29.497           Installed: 1:librbd1-0.80.7-3.el7.x86_64 (@base)
2016-03-14T14:41:29.497               librbd1 = 1:0.80.7-3.el7
2016-03-14T14:41:29.497           Available: librbd1-0.80.8-0.el7.x86_64 (Ceph)
2016-03-14T14:41:29.497               librbd1 = 0.80.8-0.el7
2016-03-14T14:41:29.498 Package: python-ceph-0.80.8-0.el7.x86_64 (Ceph)
2016-03-14T14:41:29.498           Requires: librados2 = 0.80.8-0.el7
2016-03-14T14:41:29.498           Installed: 1:librados2-0.80.7-3.el7.x86_64 (@base)
2016-03-14T14:41:29.498               librados2 = 1:0.80.7-3.el7
2016-03-14T14:41:29.498           Available: librados2-0.80.8-0.el7.x86_64 (Ceph)
2016-03-14T14:41:29.499               librados2 = 0.80.8-0.el7
2016-03-14T14:41:29.499 Package: python-ceph-0.80.8-0.el7.x86_64 (Ceph)
2016-03-14T14:41:29.499           Requires: librbd1 = 0.80.8-0.el7
2016-03-14T14:41:29.499           Installed: 1:librbd1-0.80.7-3.el7.x86_64 (@base)
2016-03-14T14:41:29.499               librbd1 = 1:0.80.7-3.el7
2016-03-14T14:41:29.500           Available: librbd1-0.80.8-0.el7.x86_64 (Ceph)
2016-03-14T14:41:29.500               librbd1 = 0.80.8-0.el7
2016-03-14T14:41:29.500 Package: ceph-radosgw-0.80.8-0.el7.x86_64 (Ceph)
2016-03-14T14:41:29.500           Requires: librados2 = 0.80.8-0.el7
2016-03-14T14:41:29.500           Installed: 1:librados2-0.80.7-3.el7.x86_64 (@base)
2016-03-14T14:41:29.501               librados2 = 1:0.80.7-3.el7
2016-03-14T14:41:29.501           Available: librados2-0.80.8-0.el7.x86_64 (Ceph)
2016-03-14T14:41:29.501               librados2 = 0.80.8-0.el7
2016-03-14T14:41:29.501 Package: ceph-common-0.80.8-0.el7.x86_64 (Ceph)
2016-03-14T14:41:29.501           Requires: librados2 = 0.80.8-0.el7
2016-03-14T14:41:29.502           Installed: 1:librados2-0.80.7-3.el7.x86_64 (@base)
2016-03-14T14:41:29.502               librados2 = 1:0.80.7-3.el7
2016-03-14T14:41:29.502           Available: librados2-0.80.8-0.el7.x86_64 (Ceph)
2016-03-14T14:41:29.502               librados2 = 0.80.8-0.el7
2016-03-14T14:41:29.502 You could try using --skip-broken to work around the problem
2016-03-14T14:41:29.775 You could try running: rpm -Va --nofiles --nodigest

this seems to happen consistently, and not be related to the node we're installing on. I don't understand why the available version matches the required version and it's erroring out..


#1 Updated by Greg Farnum almost 4 years ago

The versions don't all match; you've got a bunch of .80.7 libraries there and want .80.8. I think that means you've got EPEL packages which were pulled down as QEMU dependencies, etc, and removing them should resolve things. Or else it's the priorities problem which I don't understand at all.

#2 Updated by Ken Dreyer almost 4 years ago

  • Assignee deleted (Ken Dreyer)

firefly is EOL, right?

#3 Updated by Sage Weil almost 4 years ago

The two tests are

#11429 suites/rados/singleton-nomsgr/all/11429.yaml
#13234 suites/rados/singleton-nomsgr/all/13234.yaml

#4 Updated by Sage Weil almost 4 years ago

  • Status changed from 12 to 7

#5 Updated by Sage Weil almost 4 years ago

  • Assignee set to Sage Weil

#6 Updated by Sage Weil almost 4 years ago

  • Status changed from 7 to Resolved

#7 Updated by Nathan Cutler over 3 years ago

  • Status changed from Resolved to 12

Reopening because we are seeing this in the hammer integration testing:

#8 Updated by Nathan Cutler over 3 years ago

The librados2 0.80.7 package that is already installed on the test machine has Epoch 1 (see the "1:" prefix in the package version), while the 0.80.8 version available from the "Ceph" repo does not have the Epoch (defaults to Epoch 0):

Package: ceph-common-0.80.8-0.el7.x86_64 (Ceph)
           Requires: librados2 = 0.80.8-0.el7
           Installed: 1:librados2-0.80.7-3.el7.x86_64 (@base)
               librados2 = 1:0.80.7-3.el7
           Available: librados2-0.80.8-0.el7.x86_64 (Ceph)
               librados2 = 0.80.8-0.el7

AFAIK Epoch 1 will always trump Epoch 0.

#9 Updated by Nathan Cutler over 3 years ago

Seen again in

This issue was fixed in master by -> backporting this to hammer would presumably fix it. However, what that PR says - "we don't have el7 packages for old releases" - is not true in this case. The dumpling ceph-radosgw is available on the centos gitbuilder, so that is not the problem.

The problem is the preceding ceph-cm-ansible "TASK [testnode : Install packages]" installs qemu-kvm, which brings in librados2 and librbd1 as dependencies ("Package librados2.x86_64 1:0.80.7-3.el7 will be installed").

Later, when the install task tries to install the dumpling version of ceph-radosgw, which of course needs the dumpling librados2, it fails because this ceph-cm-ansible has already installed firefly librados2.

#10 Updated by Nathan Cutler over 3 years ago

  • Project changed from Ceph to teuthology

#11 Updated by Nathan Cutler over 3 years ago

Agreed with Sepia team and Sam that the best way to address this is to write a special version of the install task, which would force-install the packages.

#12 Updated by Nathan Cutler over 3 years ago

Reproducer is: teuthology-suite --priority 99 --suite rados --filter="rados/singleton-nomsgr/{all/11429.yaml},rados/singleton-nomsgr/{all/13234.yaml}" --suite-branch hammer --email --ceph hammer --machine-type smithi distros/all/centos_7.2.yaml

Testing it at:

#13 Updated by Nathan Cutler over 3 years ago

  • Assignee changed from Sage Weil to Nathan Cutler

#14 Updated by Nathan Cutler over 3 years ago

  • Priority changed from Urgent to Normal

#15 Updated by Nathan Cutler over 3 years ago

This continues to be a problem in hammer 0.94.10 integration testing.

#16 Updated by Nathan Cutler about 3 years ago

  • Assignee deleted (Nathan Cutler)

#17 Updated by Tamilarasi muthamizhan over 2 years ago

  • Status changed from 12 to Won't Fix

closing this bug as firefly is not supported anymore.

Also available in: Atom PDF