Project

General

Profile

Bug #15

mds rejoin: invented dirfrags (MDCache.cc:3469)

Added by Sage Weil over 9 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/09/2010
Due date:
% Done:

0%

Estimated time:
3.00 h
Source:
Tags:
Backport:
Regression:
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

invented dirfrags have version=0; subsequent modification of dentries/inodes predirty a bad (small) version #.

Associated revisions

Revision b5fd2e4d (diff)
Added by Sage Weil almost 9 years ago

mds: open undef dirfrags during rejoin

Any invented dirfrags have a version of 0. This will cause problems later
if we pre_dirty() anything in that dir because the dir version won't be
in sync (it'll be way too small). Also, we can do that at any point,
e.g. when flushing dirty caps, and aren't allowed to delay, so we need to
load those dirfrags now.

In theory we could read only the fnode and not all the dentries, but we
may as well. We should be more careful about memory that this patch is,
though.

Fixes #15.

Signed-off-by: Sage Weil <>

History

#1 Updated by Sage Weil over 9 years ago

  • Assignee set to Sage Weil

#2 Updated by Sage Weil over 9 years ago

  • Category set to 1

#3 Updated by Sage Weil almost 9 years ago

  • Target version set to v0.24
  • Estimated time set to 3.00 h
  • Source changed from 0 to 2

#4 Updated by Sage Weil almost 9 years ago

  • translation missing: en.field_position deleted (7)
  • translation missing: en.field_position set to 329

#5 Updated by Sage Weil almost 9 years ago

  • Status changed from New to Resolved

commit:b5fd2e4d4ee4bf02a993e75b756a3775b2d566e5

#6 Updated by John Spray almost 3 years ago

  • Project changed from Ceph to fs
  • Category deleted (1)
  • Target version deleted (v0.24)

Bulk updating project=ceph category=mds bugs so that I can remove the MDS category from the Ceph project to avoid confusion.

Also available in: Atom PDF