Project

General

Profile

Bug #14994

every run in ovh is failing with "__exit__"

Added by Greg Farnum over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
-
Start date:
03/07/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-03-06_23:14:01-samba-hammer---basic-openstack/

It looks like they're getting an unexpected error when provisioning machines?

2016-03-06T23:14:13.123 DEBUG:teuthology.provision:ProvisionOpenStack: {'subnet': '149.202.160.0/19', 'user-data': '/home/teuthworker/src/teuthology_master/teuthology/openstack/openstack-{os_type}-{os_version}-user-data.txt', 'ip': '149.202.184.32', 'clone': 'git clone http://github.com/ceph/teuthology', 'machine': {'disk': 20, 'ram': 8000, 'cpus': 1}, 'volumes': {'count': 0, 'size': 1}, 'flavor-select-regexp': '^(vps|eg)-', 'nameserver': '149.202.184.32'}
2016-03-06T23:14:13.123 DEBUG:teuthology.provision:ProvisionOpenStack:create
2016-03-06T23:14:13.124 DEBUG:teuthology.misc::sh: openstack image list -f json --property name='teuthology-ubuntu-14.04'
2016-03-06T23:14:13.129 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 69, in run_tasks
    manager.__enter__()
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/home/teuthworker/src/teuthology_master/teuthology/task/internal.py", line 118, in lock_machines
    os_version, arch)
  File "/home/teuthworker/src/teuthology_master/teuthology/lock.py", line 410, in lock_many
    arch=arch)
  File "/home/teuthworker/src/teuthology_master/teuthology/lock.py", line 383, in lock_many_openstack
    num, os_type, os_version, arch, resources_hint)
  File "/home/teuthworker/src/teuthology_master/teuthology/provision.py", line 306, in create
    image = self.image(os_type, os_version)
  File "/home/teuthworker/src/teuthology_master/teuthology/openstack/__init__.py", line 287, in image
    if not self.image_exists(name):
  File "/home/teuthworker/src/teuthology_master/teuthology/openstack/__init__.py", line 239, in image_exists
    self.image_name(image) + "'")
  File "/home/teuthworker/src/teuthology_master/teuthology/misc.py", line 1305, in sh
    with proc.stdout:
AttributeError: __exit__

History

#1 Updated by Yuri Weinstein over 3 years ago

dupe of #14990

#2 Updated by Loic Dachary over 3 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF