Project

General

Profile

Bug #14984

rbdmap.service should include RBDMAPFILE environment variable

Added by Paul Rawson over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

/usr/bin/rbdmap requires the RBDMAPFILE variable to be set. I've worked around this on my machines by adding Environment=RBDMAPFILE=/etc/ceph/rbdmap to the systemd unit file.

Associated revisions

Revision a7a36581 (diff)
Added by Nathan Cutler over 4 years ago

systemd: set up environment in rbdmap unit file

http://tracker.ceph.com/issues/14984 Fixes: #14984

Signed-off-by: Nathan Cutler <>

Revision c4237deb (diff)
Added by Nathan Cutler over 4 years ago

rbd: add singleton to assert no rbdmap regression

http://tracker.ceph.com/issues/14984 References: #14984

Signed-off-by: Nathan Cutler <>

Revision 0effb9e3 (diff)
Added by Nathan Cutler over 4 years ago

qa: test_rbdmap_RBDMAPFILE.sh workunit

Before a7a3658 the rbdmap script was logging bogus messages and not working
on systemd platforms because the unit file was not defining the RBDMAPFILE
environment variable.

This workunit asserts that the bug has been fixed.

http://tracker.ceph.com/issues/14984 References: #14984

Signed-off-by: Nathan Cutler <>

History

#1 Updated by Samuel Just over 4 years ago

  • Project changed from Ceph to rbd

#2 Updated by Nathan Cutler over 4 years ago

  • Status changed from New to In Progress
  • Assignee set to Nathan Cutler
  • Source changed from other to Community (user)

#3 Updated by Nathan Cutler over 4 years ago

  • Status changed from In Progress to Fix Under Review

#4 Updated by Sage Weil over 4 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF