Project

General

Profile

Bug #14920

If bluestore_sync_submit_transaction == true, make ceph don't work.

Added by jianpeng ma about 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

If bluestore_sync_submit_transaction = true; it submit transaction in _txc_state_proc.
For the extent alloca/release info need update in _kv_sync_thread. But because blustore_sync_submit_transaction == true, it don't submit transaction again.
So the extent alloca/release don't store in kv. After reboot, fsck met error.

History

#1 Updated by Sage Weil almost 3 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF