Project

General

Profile

Bug #14773

Fix message on attempt to use tell in interactive mode

Added by Nathan Cutler almost 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Development
Tags:
Backport:
hammer,infernalis
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This is the broken behavior:

$ ceph
ceph> tell osd.0 bench 1024 4096
Error: 22 EINVAL
Status:
unrecognized command! [{"prefix": "tell", "args": ["bench", "1024", "4096"]}]

It has already been fixed by:

https://github.com/ceph/ceph/commit/a341d977d42a3010267b64e15cebae3085507297


Related issues

Copied to devops - Backport #14769: hammer: Fix message on attempt to use tell in interactive mode Resolved
Copied to devops - Backport #14774: infernalis: Fix message on attempt to use tell in interactive mode Rejected

History

#1 Updated by Nathan Cutler almost 7 years ago

  • Status changed from New to Pending Backport
  • Backport set to hammer,infernalis

#2 Updated by Nathan Cutler almost 7 years ago

  • Copied to Backport #14769: hammer: Fix message on attempt to use tell in interactive mode added

#3 Updated by Nathan Cutler almost 7 years ago

  • Subject changed from Wrong error message when attempting to use tell in ceph interactive mode to Fix message on attempt to use tell in interactive mode

#4 Updated by Nathan Cutler almost 7 years ago

  • Copied to Backport #14774: infernalis: Fix message on attempt to use tell in interactive mode added

#5 Updated by Loïc Dachary over 6 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF