Project

General

Profile

Bug #14750

Objecter: do not mark OSD ops as laggy based on osd_timeout value

Added by Greg Farnum over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Objecter
Target version:
-
Start date:
02/12/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

We are currently looking at Objecter::osd_timeout when determining if OSD ops are laggy in Objecter::tick(). This happened in commit ecf2bebe9, which mistakenly switched it from looking at the config option objecter_timeout.

Since the osd_timeout is usually zero, meaning we don't want to get ETIMEDOUT on ops, that means that we mark ops as laggy whenever we tick(), and subscribe to osdmaps from the monitor. Yikes!

History

#1 Updated by Greg Farnum over 3 years ago

  • Status changed from New to Testing

#2 Updated by Greg Farnum over 3 years ago

  • Status changed from Testing to Resolved

Also available in: Atom PDF