Project

General

Profile

Tasks #14692

hammer v0.94.7

Added by Loic Dachary over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
% Done:

0%

Tags:
Reviewed:
Affected Versions:
Pull request ID:

Description

Workflow

  • Preparing the release
  • Cutting the release
    • Nathan asks Sage if a point release should be published YES
    • Nathan gets approval from all leads
      • Yehuda, rgw YES
      • Gregory, CephFS YES
      • Jason, RBD YES
      • Sam, rados YES
    • Sage writes and commits the release notes IN PROGRESS
    • Nathan informs Yuri that the branch is ready for testing
    • Yuri runs additional integration tests "DONE"
    • If Yuri discovers new bugs that need to be backported urgently (i.e. their priority is set to Urgent), the release goes back to being prepared, it was not ready after all
    • Yuri informs Alfredo that the branch is ready for release DONE
    • Alfredo creates the packages and sets the release tag DONE

Release information

History

#1 Updated by Loic Dachary over 4 years ago

git --no-pager log --format='%H %s' --graph ceph/hammer..hammer-backports | perl -p -e 's/"/ /g; if (/\w+\s+Merge pull request #(\d+)/) { s|\w+\s+Merge pull request #(\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

#2 Updated by Loic Dachary over 4 years ago

fs

teuthology-suite --priority 1000 --suite fs --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=3/5

Re-running failed jobs

#3 Updated by Loic Dachary over 4 years ago

rgw

teuthology-suite --priority 1000 --suite rgw --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --distro ubuntu --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=2/5

#4 Updated by Loic Dachary over 4 years ago

powercycle

teuthology-suite -l2 -v -c hammer-backports -k testing -m smithi -s powercycle -p 1000 --email loic@dachary.org

#5 Updated by Loic Dachary over 4 years ago

upgrade

teuthology-suite --verbose --suite upgrade/hammer --suite-branch hammer --ceph hammer-backports --machine-type vps --priority 1000 machine_types/vps.yaml

Re-running failed tests

#6 Updated by Loic Dachary over 4 years ago

rados

teuthology-suite --priority 1000 --suite rados --subset $(expr $RANDOM % 18)/18 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=9/18

Re-running failed tests

#7 Updated by Loic Dachary over 4 years ago

rbd

teuthology-suite --priority 1000 --suite rbd --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=0/5

#8 Updated by Loic Dachary over 4 years ago

git --no-pager log --format='%H %s' --graph ceph/hammer..hammer-backports | perl -p -e 's/"/ /g; if (/\w+\s+Merge pull request #(\d+)/) { s|\w+\s+Merge pull request #(\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

#9 Updated by Loic Dachary over 4 years ago

rados

teuthology-suite --priority 1000 --suite rados --subset $(expr $RANDOM % 18)/18 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=6/18

Re-running failed tests

#10 Updated by Loic Dachary over 4 years ago

rbd

teuthology-suite --priority 1000 --suite rbd --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=1/5

Re-running failed tests

#11 Updated by Loic Dachary over 4 years ago

upgrade

teuthology-suite --verbose --suite upgrade/hammer --suite-branch hammer --ceph hammer-backports --machine-type vps --priority 1000 machine_types/vps.yaml

Re-running failed tests

Re-running failed tests

#12 Updated by Loic Dachary over 4 years ago

git --no-pager log --format='%H %s' --graph ceph/hammer..hammer-backports | perl -p -e 's/"/ /g; if (/\w+\s+Merge pull request #(\d+)/) { s|\w+\s+Merge pull request #(\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

#13 Updated by Loic Dachary over 4 years ago

rados

teuthology-suite --priority 1000 --suite rados --subset $(expr $RANDOM % 18)/18 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=14/18

Re-running failed tests

#14 Updated by Loic Dachary over 4 years ago

upgrade

teuthology-suite --verbose --suite upgrade/hammer --suite-branch hammer --ceph hammer-backports --machine-type vps --priority 1000 machine_types/vps.yaml

Re-running failed tests

Re-running failed tests

#15 Updated by Loic Dachary over 4 years ago

rgw

teuthology-suite --priority 1000 --suite rgw --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --distro ubuntu --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=0/5

Re-running the failed test:

#16 Updated by Loic Dachary over 4 years ago

rbd

teuthology-suite --priority 1000 --suite rbd --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=1/5

#17 Updated by Loic Dachary over 4 years ago

powercycle

teuthology-suite -l2 -v -c hammer-backports -k testing -m smithi -s powercycle -p 1000 --email loic@dachary.org

#18 Updated by Loic Dachary over 4 years ago

fs

teuthology-suite --priority 1000 --suite fs --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=2/5

#19 Updated by Loic Dachary over 4 years ago

git --no-pager log --format='%H %s' --graph ceph/hammer..hammer-backports | perl -p -e 's/"/ /g; if (/\w+\s+Merge pull request #(\d+)/) { s|\w+\s+Merge pull request #(\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

#20 Updated by Loic Dachary over 4 years ago

rados

teuthology-suite --priority 1000 --suite rados --subset $(expr $RANDOM % 18)/18 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=?????/18

Re-running failed tests

#21 Updated by Loic Dachary over 4 years ago

upgrade

teuthology-suite --verbose --suite upgrade/hammer --suite-branch hammer --ceph hammer-backports --machine-type vps --priority 1000 --email loic@dachary.org machine_types/vps.yaml

Re-running failed tests

#22 Updated by Loic Dachary over 4 years ago

rgw

teuthology-suite --priority 1000 --suite rgw --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --distro ubuntu --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=????/5

Re-running failed tests

#23 Updated by Loic Dachary over 4 years ago

rbd

teuthology-suite --priority 1000 --suite rbd --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=????/5

#24 Updated by Loic Dachary over 4 years ago

powercycle

teuthology-suite -l2 -v -c hammer-backports -k testing -m smithi -s powercycle -p 1000 --email loic@dachary.org

#25 Updated by Loic Dachary over 4 years ago

fs

teuthology-suite --priority 1000 --suite fs --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=0/5

  • fail http://pulpito.ceph.com/loic-2016-02-28_22:01:06-fs-hammer-backports---basic-multi
    • 'sudo adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage daemon-helper kill ceph-osd -f -i 3'
    • , 'msg': '\'/usr/bin/apt-get -y -o "Dpkg::Options::=--force-confdef" -o "Dpkg::Options::=--force-confold" install \'qemu-system-x86\' \'libfcgi\' \'dmapi\' \'tgt\'\' failed: E: There are problems and -y was used without --force-yes\n'}, 'mira032.front.sepia.ceph.com': {'item': 'libgoogle-perftools4,libboost-thread1.54.0,mpich,qemu-system-x86,lttng-tools,libfcgi0ldbl,python-virtualenv,python-dev,libevent-dev,perl,libwww-perl,lsb-release,build-essential,sysstat,gdb,python-configobj,python-gevent,libedit2,libssl0.9.8,cryptsetup-bin,xfsprogs,gdisk,parted,smbios-utils,libcrypto++9,libuuid1,libfcgi,btrfs-tools,libatomic-ops-dev,git-core,attr,dbench,bonnie++,iozone3,valgrind,python-nose,mpich2,libmpich2-dev,ant,libtool,automake,gettext,uuid-dev,libacl1-dev,bc,xfsdump,dmapi,xfslibs-dev,libattr1-dev,quota,libcap2-bin,libncurses5-dev,lvm2,sysprof,vim,pdsh,collectl,blktrace,python-numpy,python-matplotlib,genisoimage,libjson-xs-perl,xml-twig-tools,default-jdk,junit4,tgt,open-iscsi,smartmontools,nagios-nrpe-server,cifs-utils,ipcalc,nfs-common,nfs-kernel-server', 'failed': True, 'stderr': 'E: There are problems and -y was used without --force-yes\n', 'stdout': 'Reading package lists...\nBuilding dependency tree...\nReading state information...\nlibfcgi0ldbl is already the newest version.\nlibdm0 is already the newest version.\nThe following extra packages will be installed:\n librados2 librbd1 qemu-utils\nSuggested packages:\n samba vde2 sgabios kvm-ipxe-precise debootstrap\nThe following NEW packages will be installed:\n librados2 librbd1 qemu-system-x86 qemu-utils tgt\n0 upgraded, 5 newly installed, 0 to remove and 103 not upgraded.\nNeed to get 0 B/4313 kB of archives.\nAfter this operation, 22.6 MB of additional disk space will be used.\nWARNING: The following packages cannot be authenticated!\n librados2 librbd1 tgt\n', 'invocation': {'module_name': 'apt', 'module_args': ''}, 'msg': '\'/usr/bin/apt-get -y -o "Dpkg::Options::=--force-confdef" -o "Dpkg::Options::=--force-confold" install \'qemu-system-x86\' \'libfcgi\' \'dmapi\' \'tgt\'\' failed: E: There are problems and -y was used without --force-yes\n'}}
    • , 'msg': '\'/usr/bin/apt-get -y -o "Dpkg::Options::=--force-confdef" -o "Dpkg::Options::=--force-confold" install \'qemu-system-x86\' \'libfcgi\' \'dmapi\' \'tgt\'\' failed: E: There are problems and -y was used without --force-yes\n'}, 'mira108.front.sepia.ceph.com': {'item': 'libgoogle-perftools4,libboost-thread1.54.0,mpich,qemu-system-x86,lttng-tools,libfcgi0ldbl,python-virtualenv,python-dev,libevent-dev,perl,libwww-perl,lsb-release,build-essential,sysstat,gdb,python-configobj,python-gevent,libedit2,libssl0.9.8,cryptsetup-bin,xfsprogs,gdisk,parted,smbios-utils,libcrypto++9,libuuid1,libfcgi,btrfs-tools,libatomic-ops-dev,git-core,attr,dbench,bonnie++,iozone3,valgrind,python-nose,mpich2,libmpich2-dev,ant,libtool,automake,gettext,uuid-dev,libacl1-dev,bc,xfsdump,dmapi,xfslibs-dev,libattr1-dev,quota,libcap2-bin,libncurses5-dev,lvm2,sysprof,vim,pdsh,collectl,blktrace,python-numpy,python-matplotlib,genisoimage,libjson-xs-perl,xml-twig-tools,default-jdk,junit4,tgt,open-iscsi,smartmontools,nagios-nrpe-server,cifs-utils,ipcalc,nfs-common,nfs-kernel-server', 'failed': True, 'stderr': 'E: There are problems and -y was used without --force-yes\n', 'stdout': 'Reading package lists...\nBuilding dependency tree...\nReading state information...\nlibfcgi0ldbl is already the newest version.\nlibdm0 is already the newest version.\nThe following extra packages will be installed:\n cpu-checker ipxe-qemu libbluetooth3 libbrlapi0.6 libcaca0\n libconfig-general-perl libfdt1 libibverbs1 librados2 librbd1 librdmacm1\n libsdl1.2debian libseccomp2 libsgutils2-2 libspice-server1\n libusbredirparser1 libxen-4.4 libxenstore3.0 libyajl2 msr-tools qemu-keymaps\n qemu-system-common qemu-utils seabios sg3-utils sharutils\nSuggested packages:\n samba vde2 sgabios kvm-ipxe-precise debootstrap\nThe following NEW packages will be installed:\n cpu-checker ipxe-qemu libbluetooth3 libbrlapi0.6 libcaca0\n libconfig-general-perl libfdt1 libibverbs1 librados2 librbd1 librdmacm1\n libsdl1.2debian libseccomp2 libsgutils2-2 libspice-server1\n libusbredirparser1 libxen-4.4 libxenstore3.0 libyajl2 msr-tools qemu-keymaps\n qemu-system-common qemu-system-x86 qemu-utils seabios sg3-utils sharutils\n tgt\n0 upgraded, 28 newly installed, 0 to remove and 102 not upgraded.\nNeed to get 0 B/7120 kB of archives.\nAfter this operation, 33.5 MB of additional disk space will be used.\nWARNING: The following packages cannot be authenticated!\n libbluetooth3 librados2 librbd1 libsdl1.2debian libusbredirparser1\n libibverbs1 ipxe-qemu seabios tgt\n', 'invocation': {'module_name': 'apt', 'module_args': ''}, 'msg': '\'/usr/bin/apt-get -y -o "Dpkg::Options::=--force-confdef" -o "Dpkg::Options::=--force-confold" install \'qemu-system-x86\' \'libfcgi\' \'dmapi\' \'tgt\'\' failed: E: There are problems and -y was used without --force-yes\n'}}

Re-running failed tests

Trying on hammer

teuthology-suite --priority 1000 --suite fs --filter="fs/recovery/{clusters/2-remote-clients.yaml debug/mds_client.yaml mounts/ceph-fuse.yaml tasks/mds-full.yaml}" --suite-branch hammer --email loic@dachary.org --ceph hammer --machine-type smithi,mira teuthology-suite --priority 1000 --suite fs --filter="fs/recovery/{clusters/2-remote-clients.yaml debug/mds_client.yaml mounts/ceph-fuse.yaml tasks/mds-full.yaml}" --suite-branch hammer --email loic@dachary.org --ceph v0.94.6 --machine-type smithi,mira

The same test failed February 8th, 2016 http://pulpito.ceph.com/loic-2016-02-08_23:43:36-fs-hammer-backports---basic-multi/1087/
The same test passed January 29th, 2016 http://pulpito.ceph.com/loic-2016-01-29_03:02:05-fs-hammer---basic-multi/49423/

git log --merges --since 2016-01-29 --until 2016-02-07 --format='%H' ceph/hammer | \
while read sha1 ; do \
  echo ; git log --format='** %aD "%s":https://github.com/ceph/ceph/commit/%H' ${sha1}^1..${sha1} ; \
done | perl -p -e 'print "* \"PR $1\":https://github.com/ceph/ceph/pull/$1\n" if(/Merge pull request #(\d+)/)'

The most likely candidate for this regression is : https://github.com/ceph/ceph/pull/6918 hammer: osd: check for full before changing the cached obc (hammer)

Trying on v0.94.5

#26 Updated by Loic Dachary over 4 years ago

git --no-pager log --format='%H %s' --graph ceph/hammer..hammer-backports-loic | perl -p -e 's/"/ /g; if (/\w+\s+Merge pull request #(\d+)/) { s|\w+\s+Merge pull request #(\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

#27 Updated by Loic Dachary over 4 years ago

rados

teuthology-suite --priority 1000 --suite rados --subset $(expr $RANDOM % 18)/18 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

Re-running failed tests

#28 Updated by Loic Dachary over 4 years ago

rbd

teuthology-suite --priority 1000 --suite rbd --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports-loic --machine-type smithi,mira

Re-running failed tests

#29 Updated by Loic Dachary over 4 years ago

upgrade

teuthology-suite --verbose --suite upgrade/hammer --suite-branch hammer --ceph hammer-backports-loic --machine-type vps --priority 1000 machine_types/vps.yaml

Re-running failed tests

#30 Updated by Loic Dachary over 4 years ago

git --no-pager log --format='%H %s' --graph ceph/hammer..ceph/hammer-backports | perl -p -e 's/"/ /g; if (/\w+\s+Merge pull request #(\d+)/) { s|\w+\s+Merge pull request #(\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

#31 Updated by Loic Dachary over 4 years ago

upgrade

teuthology-suite --verbose --suite upgrade/hammer --suite-branch hammer --ceph hammer-backports --machine-type vps --priority 1000 machine_types/vps.yaml

Re-running failed tests

Re-running failed tests

#32 Updated by Loic Dachary over 4 years ago

rados

teuthology-suite --priority 1000 --suite rados --subset $(expr $RANDOM % 18)/18 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=4/18

Re-running failed tests

Re-running failed tests

Re-running failed tests (on smithi in an attempt to fix what appears to be a timing issue)

#33 Updated by Loic Dachary over 4 years ago

rbd

teuthology-suite --priority 1000 --suite rbd --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=1/5

Re-running failed tests

#34 Updated by Loic Dachary over 4 years ago

fs

teuthology-suite --priority 1000 --suite fs --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=0/5

Re-running failed jobs

#35 Updated by Loic Dachary over 4 years ago

powercycle

teuthology-suite -l2 -v -c hammer-backports -k testing -m smithi -s powercycle -p 1000 --email loic@dachary.org

#36 Updated by Loic Dachary over 4 years ago

rgw

teuthology-suite --priority 1000 --suite rgw --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi,mira

INFO:teuthology.suite:Passed subset=2/5

Re-running failed tests

Opened bug #15044 for the infrastructure issue and re-running the last remaining failed test:

./virtualenv/bin/teuthology-suite --priority 1000 --suite rgw --suite-branch hammer --email ncutler@suse.cz --ceph hammer-backports --machine-type smithi,mira --filter "rgw/multifs/{overrides.yaml clusters/fixed-2.yaml frontend/civetweb.yaml fs/ext4.yaml rgw_pool_type/ec-cache.yaml tasks/rgw_s3tests.yaml}"

#37 Updated by Loic Dachary over 4 years ago

git --no-pager log --format='%H %s' --graph ceph/hammer..hammer-backports | perl -p -e 's/"/ /g; if (/\w+\s+Merge (\d+)/) { s|\w+\s+Merge (\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

#38 Updated by Loic Dachary over 4 years ago

upgrade

teuthology-suite --verbose --suite upgrade/hammer --suite-branch hammer --ceph hammer-backports --machine-type vps --priority 1000 machine_types/vps.yaml
  • red http://pulpito.ceph.com/loic-2016-03-12_17:31:24-upgrade:hammer-hammer-backports---basic-vps/
    • 56440, 56456, 56501 new bug? RuntimeError: Fuse mount failed to populate /sys/ after 31 seconds - this looks like #12506, but Zheng says that one does not affect hammer. Zheng's analysis of the teuthology log: "seem like ceph-fuse failed to connect to monitor - no idea why" - smithfarm analysis: "looking more closely at the log, I see: Running task ceph-fuse..., then Mounting ceph-fuse clients..., then mon_thrasher:start thrashing, then sudo mount -t fusectl /sys/fs/fuse/connections /sys/fs/fuse/connections, and finally mount point /sys/fs/fuse/connections does not exist"
    • 56468, 56486, 56488, 56498, 56504, 56511, 56517, 56523 unresponsive mira007 reported at http://tracker.ceph.com/issues/15116 Downburst failed on ubuntu@vpm033.front.sepia.ceph.com: libvirt: XML-RPC error : Cannot recv data: ssh: connect to host mira007.front.sepia.ceph.com port 22: No route to host: Connection reset by peer
    • 56470 mon daemon fails to restart, leading to dead job vpm149 runs workunit test suites/dbench.sh which seems to take an unusually long time in the cleanup phase, and eventually exceeds 3 hour timeout

Rerunning failed and dead jobs:

Rerunning 2 failed jobs:

#39 Updated by Loic Dachary over 4 years ago

rados

teuthology-suite --priority 1000 --suite rados --subset $(expr $RANDOM % 18)/18 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi

INFO:teuthology.suite:Passed subset=7/18

Fails for the following reasons and discarded the results.

#40 Updated by Loic Dachary over 4 years ago

rbd

teuthology-suite --priority 1000 --suite rbd --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi

INFO:teuthology.suite:Passed subset=3/5

Re-running failed tests

#42 Updated by Loic Dachary over 4 years ago

powercycle

teuthology-suite -l2 -v -c hammer-backports -k testing -m smithi -s powercycle -p 1000 --email loic@dachary.org

#43 Updated by Loic Dachary over 4 years ago

rgw

teuthology-suite --priority 1000 --suite rgw --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi

INFO:teuthology.suite:Passed subset=2/5

Re-running failed tests

#44 Updated by Loic Dachary over 4 years ago

git --no-pager log --format='%H %s' --graph ceph/hammer..hammer-backports | perl -p -e 's/"/ /g; if (/\w+\s+Merge (\d+)/) { s|\w+\s+Merge (\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

#45 Updated by Loic Dachary over 4 years ago

rados

teuthology-suite --priority 1000 --suite rados --subset $(expr $RANDOM % 2000)/2000 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi

INFO:teuthology.suite:Passed subset=488/2000

#46 Updated by Loic Dachary over 4 years ago

rgw

teuthology-suite --priority 1000 --suite rgw --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi

INFO:teuthology.suite:Passed subset=4/5

Re-running failed tests

#47 Updated by Loic Dachary over 4 years ago

powercycle

teuthology-suite -l2 -v -c hammer-backports -k testing -m smithi -s powercycle -p 1000 --email loic@dachary.org

#48 Updated by Loic Dachary over 4 years ago

fs

teuthology-suite --priority 1000 --suite fs --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi

INFO:teuthology.suite:Passed subset=1/5

  • fail http://pulpito.ceph.com/loic-2016-04-05_04:42:58-fs-hammer-backports---basic-smithi
    • 'TESTDIR=/home/ubuntu/cephtest bash -s'
    • 'mkdir -- /home/ubuntu/cephtest/workunit.client.0 && git archive --remote=git://git.ceph.com/ceph.git 0eb9d5598ac1dfbca0e679722f2e86f9270d2bc4:qa/workunits | tar C /home/ubuntu/cephtest/workunit.client.0 -x -f'
    • , 'failed': True, 'item': 'http://download.ceph.com/keys/release.asc', 'msg': 'Failed to download key at http://download.ceph.com/keys/release.asc: Request failed: <urlopen error [Errno -2] Name or service not known>'}, 'smithi035.front.sepia.ceph.com': {'invocation': {'module_name': 'apt_key', 'module_args': ''}, 'failed': True, 'item': 'http://download.ceph.com/keys/release.asc', 'msg': 'Failed to download key at http://download.ceph.com/keys/release.asc: Request failed: <urlopen error [Errno -2] Name or service not known>'}, 'smithi011.front.sepia.ceph.com': {'item': '@core,@base,yum-plugin-priorities,yum-plugin-fastestmirror,redhat-lsb,sysstat,gdb,git-all,python-configobj,libedit,openssl098e,boost-thread,xfsprogs,gdisk,parted,libgcrypt,fuse,fuse-libs,python-virtualenv,openssl,libuuid,btrfs-progs,attr,valgrind,python-nose,mpich,ant,iozone,libtool,automake,gettext,libuuid-devel,libacl-devel,bc,xfsdump,xfsprogs-devel,blktrace,numpy,python-matplotlib,qemu-kvm,usbredir,genisoimage,httpd,httpd-devel,httpd-tools,mod_ssl,mod_fastcgi-2.4.7-1.ceph.el7.centos,libevent-devel,perl-XML-Twig,java-1.6.0-openjdk-devel,junit4,smartmontools,nfs-utils,ncurses-devel', 'rc': 1, 'invocation': {'module_name': 'yum', 'module_args': ''}, 'changed': True, 'results': ['yum-plugin-priorities-1.1.31-34.el7.noarch providing yum-plugin-priorities is already installed', 'yum-plugin-fastestmirror-1.1.31-34.el7.noarch providing yum-plugin-fastestmirror is already installed', 'redhat-lsb-4.1-27.el7.centos.1.x86_64 providing redhat-lsb is already installed', 'sysstat-10.1.5-7.el7.x86_64 providing sysstat is already installed', 'gdb-7.6.1-80.el7.x86_64 providing gdb is already installed', 'git-all-1.8.3.1-6.el7.noarch providing git-all is already installed', 'python-configobj-4.7.2-7.el7.noarch providing python-configobj is already installed', 'libedit-3.0-12.20121213cvs.el7.x86_64 providing libedit is already installed', 'openssl098e-0.9.8e-29.el7.centos.3.x86_64 providing openssl098e is already installed', 'boost-thread-1.53.0-25.el7.x86_64 providing boost-thread is already installed', 'xfsprogs-3.2.2-2.el7.x86_64 providing xfsprogs is already installed', 'gdisk-0.8.6-5.el7.x86_64 providing gdisk is already installed', 'parted-3.1-23.el7.x86_64 providing parted is already installed', 'libgcrypt-1.5.3-12.el7_1.1.x86_64 providing libgcrypt is already installed', 'fuse-2.9.2-6.el7.x86_64 providing fuse is already installed', 'fuse-libs-2.9.2-6.el7.x86_64 providing fuse-libs is already installed', 'python-virtualenv-1.10.1-2.el7.noarch providing python-virtualenv is already installed', 'openssl-1.0.1e-42.el7.9.x86_64 providing openssl is already installed', 'libuuid-2.23.2-26.el7.x86_64 providing libuuid is already installed', 'btrfs-progs-3.19.1-1.el7.x86_64 providing btrfs-progs is already installed', 'attr-2.4.46-12.el7.x86_64 providing attr is already installed', 'valgrind-3.10.0-16.el7.x86_64 providing valgrind is already installed', 'python-nose-1.3.0-3.el7.noarch providing python-nose is already installed', 'mpich-3.0.4-8.el7.x86_64 providing mpich is already installed', 'ant-1.9.2-9.el7.noarch providing ant is already installed', 'libtool-2.4.2-21.el7_2.x86_64 providing libtool is already installed', 'automake-1.13.4-3.el7.noarch providing automake is already installed', 'gettext-0.18.2.1-4.el7.x86_64 providing gettext is already installed', 'libuuid-devel-2.23.2-26.el7.x86_64 providing libuuid-devel is already installed', 'libacl-devel-2.2.51-12.el7.x86_64 providing libacl-devel is already installed', 'bc-1.06.95-13.el7.x86_64 providing bc is already installed', 'xfsdump-3.1.4-1.el7.x86_64 providing xfsdump is already installed', 'xfsprogs-devel-3.2.2-2.el7.x86_64 providing xfsprogs-devel is already installed', 'blktrace-1.0.5-6.el7.x86_64 providing blktrace is already installed', 'numpy-1.7.1-11.el7.x86_64 providing numpy is already installed', 'python-matplotlib-1.2.0-15.el7.x86_64 providing python-matplotlib is already installed', 'usbredir-0.6-7.el7.x86_64 providing usbredir is already installed', 'genisoimage-1.1.11-23.el7.x86_64 providing genisoimage is already installed', 'httpd-2.4.6-40.el7.centos.x86_64 providing httpd is already installed', 'httpd-devel-2.4.6-40.el7.centos.x86_64 providing httpd-devel is already installed', 'httpd-tools-2.4.6-40.el7.centos.x86_64 providing httpd-tools is already installed', 'mod_ssl-2.4.6-40.el7.centos.x86_64 providing mod_ssl is already installed', 'libevent-devel-2.0.21-4.el7.x86_64 providing libevent-devel is already installed', 'perl-XML-Twig-3.44-2.el7.noarch providing perl-XML-Twig is already installed', 'java-1.6.0-openjdk-devel-1.6.0.38-1.13.10.0.el7_2.x86_64 providing java-1.6.0-openjdk-devel is already installed', 'junit-4.11-8.el7.noarch providing junit4 is already installed', 'smartmontools-6.2-4.el7.x86_64 providing smartmontools is already installed', 'nfs-utils-1.3.0-0.21.el7_2.x86_64 providing nfs-utils is already installed', 'ncurses-devel-5.9-13.20130511.el7.x86_64 providing ncurses-devel is already installed', 'Loaded plugins: fastestmirror, langpacks, priorities\nLoading mirror speeds from cached hostfile\n * base: mirror.es.its.nyu.edu\n * epel: fedora-epel.mirror.lstn.net\n * extras: mirror.ash.fastserv.com\n * updates: mirror.cogentco.com\nResolving Dependencies\n--> Running transaction check\n---> Package iozone.x86_64 0:3.424-2_ceph.el7.centos will be installed\n---> Package mod_fastcgi.x86_64 0:2.4.7-1.ceph.el7.centos will be installed\n---> Package qemu-kvm.x86_64 10:1.5.3-105.el7_2.3 will be installed\n--> Processing Dependency: qemu-kvm-common = 10:1.5.3-105.el7_2.3 for package: 10:qemu-kvm-1.5.3-105.el7_2.3.x86_64\n--> Processing Dependency: qemu-img = 10:1.5.3-105.el7_2.3 for package: 10:qemu-kvm-1.5.3-105.el7_2.3.x86_64\n--> Processing Dependency: librbd.so.1()(64bit) for package: 10:qemu-kvm-1.5.3-105.el7_2.3.x86_64\n--> Processing Dependency: librados.so.2()(64bit) for package: 10:qemu-kvm-1.5.3-105.el7_2.3.x86_64\n--> Running transaction check\n---> Package librados2.x86_64 1:0.80.7-3.el7 will be installed\n---> Package librbd1.x86_64 1:0.80.7-3.el7 will be installed\n---> Package qemu-img.x86_64 10:1.5.3-105.el7_2.3 will be installed\n---> Package qemu-kvm-common.x86_64 10:1.5.3-105.el7_2.3 will be installed\n--> Finished Dependency Resolution\n\nDependencies Resolved\n\n================================================================================\n Package Arch Version Repository Size\n================================================================================\nInstalling:\n iozone x86_64 3.424-2_ceph.el7.centos lab-extras 800 k\n mod_fastcgi x86_64 2.4.7-1.ceph.el7.centos centos7-fcgi-ceph 70 k\n qemu-kvm x86_64 10:1.5.3-105.el7_2.3 updates 1.8 M\nInstalling for dependencies:\n librados2 x86_64 1:0.80.7-3.el7 base 1.5 M\n librbd1 x86_64 1:0.80.7-3.el7 base 350 k\n qemu-img x86_64 10:1.5.3-105.el7_2.3 updates 657 k\n qemu-kvm-common x86_64 10:1.5.3-105.el7_2.3 updates 391 k\n\nTransaction Summary\n================================================================================\nInstall 3 Packages (+4 Dependent packages)\n\nTotal download size: 5.6 M\nInstalled size: 17 M\nDownloading packages:\n'], 'msg': 'http://mirror.es.its.nyu.edu/centos/7.2.1511/os/x86_64/Packages/librbd1-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.es.its.nyu.edu; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.es.its.nyu.edu/centos/7.2.1511/os/x86_64/Packages/librados2-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.es.its.nyu.edu; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.cogentco.com/pub/linux/centos/7.2.1511/updates/x86_64/Packages/qemu-img-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.cogentco.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.cogentco.com/pub/linux/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.cogentco.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.cogentco.com/pub/linux/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-common-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.cogentco.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://centos.firehosted.com/7.2.1511/os/x86_64/Packages/librbd1-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: centos.firehosted.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.confluxtech.com/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.confluxtech.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.confluxtech.com/centos/7.2.1511/os/x86_64/Packages/librados2-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.confluxtech.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.steadfast.net/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-common-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.steadfast.net; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.steadfast.net/centos/7.2.1511/os/x86_64/Packages/librbd1-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.steadfast.net; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.tzulo.com/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.tzulo.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://centos.chi.host-engine.com/7.2.1511/os/x86_64/Packages/librados2-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: centos.chi.host-engine.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://cosmos.illinois.edu/pub/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-common-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: cosmos.illinois.edu; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.millry.co/CentOS/7.2.1511/os/x86_64/Packages/librbd1-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.millry.co; Temporary failure in name resolution"\nTrying other mirror.\nhttp://repos.dfw.quadranet.com/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: repos.dfw.quadranet.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.us.oneandone.net/linux/distributions/centos/7.2.1511/os/x86_64/Packages/librados2-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.us.oneandone.net; Temporary failure in name resolution"\nTrying other mirror.\nhttp://dallas.tx.mirror.xygenhosting.com/CentOS/7.2.1511/updates/x86_64/Packages/qemu-kvm-common-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: dallas.tx.mirror.xygenhosting.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://denver.gaminghost.co/7.2.1511/os/x86_64/Packages/librbd1-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: denver.gaminghost.co; Temporary failure in name resolution"\nTrying other mirror.\nhttp://centos.mirror.ndchost.com/7.2.1511/updates/x86_64/Packages/qemu-kvm-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: centos.mirror.ndchost.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://dist1.800hosting.com/centos/7.2.1511/os/x86_64/Packages/librados2-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: dist1.800hosting.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://dist1.800hosting.com/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-common-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: dist1.800hosting.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirrors.tummy.com/mirrors/CentOS/7.2.1511/os/x86_64/Packages/librbd1-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirrors.tummy.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://centos.mirror.nac.net/7.2.1511/updates/x86_64/Packages/qemu-kvm-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: centos.mirror.nac.net; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirrors.tummy.com/mirrors/CentOS/7.2.1511/os/x86_64/Packages/librados2-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirrors.tummy.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://centos.mirror.nac.net/7.2.1511/updates/x86_64/Packages/qemu-kvm-common-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: centos.mirror.nac.net; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.confluxtech.com/centos/7.2.1511/os/x86_64/Packages/librbd1-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.confluxtech.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.steadfast.net/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.steadfast.net; Temporary failure in name resolution"\nTrying other mirror.\nhttp://centos.firehosted.com/7.2.1511/os/x86_64/Packages/librados2-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: centos.firehosted.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://cosmos.illinois.edu/pub/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: cosmos.illinois.edu; Temporary failure in name resolution"\nTrying other mirror.\nhttp://centos.chi.host-engine.com/7.2.1511/os/x86_64/Packages/librbd1-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: centos.chi.host-engine.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.millry.co/CentOS/7.2.1511/os/x86_64/Packages/librados2-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.millry.co; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.confluxtech.com/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-common-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.confluxtech.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://dallas.tx.mirror.xygenhosting.com/CentOS/7.2.1511/updates/x86_64/Packages/qemu-kvm-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: dallas.tx.mirror.xygenhosting.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.us.oneandone.net/linux/distributions/centos/7.2.1511/os/x86_64/Packages/librbd1-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.us.oneandone.net; Temporary failure in name resolution"\nTrying other mirror.\nhttp://denver.gaminghost.co/7.2.1511/os/x86_64/Packages/librados2-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: denver.gaminghost.co; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.tzulo.com/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-common-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.tzulo.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://dist1.800hosting.com/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: dist1.800hosting.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.steadfast.net/centos/7.2.1511/os/x86_64/Packages/librados2-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.steadfast.net; Temporary failure in name resolution"\nTrying other mirror.\nhttp://repos.dfw.quadranet.com/centos/7.2.1511/updates/x86_64/Packages/qemu-kvm-common-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: repos.dfw.quadranet.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://dist1.800hosting.com/centos/7.2.1511/os/x86_64/Packages/librbd1-0.80.7-3.el7.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: dist1.800hosting.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://centos.mirror.ndchost.com/7.2.1511/updates/x86_64/Packages/qemu-kvm-common-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: centos.mirror.ndchost.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://centos.mirror.nac.net/7.2.1511/updates/x86_64/Packages/qemu-img-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#7 - "Failed connect to centos.mirror.nac.net:80; Connection timed out"\nTrying other mirror.\nhttp://cosmos.illinois.edu/pub/centos/7.2.1511/updates/x86_64/Packages/qemu-img-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: cosmos.illinois.edu; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.confluxtech.com/centos/7.2.1511/updates/x86_64/Packages/qemu-img-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.confluxtech.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://dallas.tx.mirror.xygenhosting.com/CentOS/7.2.1511/updates/x86_64/Packages/qemu-img-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: dallas.tx.mirror.xygenhosting.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.tzulo.com/centos/7.2.1511/updates/x86_64/Packages/qemu-img-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.tzulo.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://mirror.steadfast.net/centos/7.2.1511/updates/x86_64/Packages/qemu-img-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: mirror.steadfast.net; Temporary failure in name resolution"\nTrying other mirror.\nhttp://repos.dfw.quadranet.com/centos/7.2.1511/updates/x86_64/Packages/qemu-img-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: repos.dfw.quadranet.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://dist1.800hosting.com/centos/7.2.1511/updates/x86_64/Packages/qemu-img-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: dist1.800hosting.com; Temporary failure in name resolution"\nTrying other mirror.\nhttp://centos.mirror.ndchost.com/7.2.1511/updates/x86_64/Packages/qemu-img-1.5.3-105.el7_2.3.x86_64.rpm: [Errno 14] curl#6 - "Could not resolve host: centos.mirror.ndchost.com; Temporary failure in name resolution"\nTrying other mirror.\n\n\nError downloading packages:\n 1:librados2-0.80.7-3.el7.x86_64: [Errno 256] No more mirrors to try.\n 10:qemu-img-1.5.3-105.el7_2.3.x86_64: [Errno 256] No more mirrors to try.\n 10:qemu-kvm-1.5.3-105.el7_2.3.x86_64: [Errno 256] No more mirrors to try.\n 10:qemu-kvm-common-1.5.3-105.el7_2.3.x86_64: [Errno 256] No more mirrors to try.\n 1:librbd1-0.80.7-3.el7.x86_64: [Errno 256] No more mirrors to try.\n\n'}}
    • while scanning a simple key
      in "/tmp/teuth_ansible_failures_SF2WYn", line 15, column 1
      could not found expected ':'
      in "/tmp/teuth_ansible_failures_SF2WYn", line 22, column 216
    • Stale /var/lib/ceph detected, aborting.
    • 'sudo adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage daemon-helper kill ceph-osd -f -i 3'
    • {'smithi043.front.sepia.ceph.com': 'SSH Error: data could not be sent to the remote host. Make sure this host can be reached over ssh'}
    • saw valgrind issues

#49 Updated by Loic Dachary over 4 years ago

rbd

teuthology-suite --priority 1000 --suite rbd --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --email loic@dachary.org --ceph hammer-backports --machine-type smithi

INFO:teuthology.suite:Passed subset=2/5

#50 Updated by Loic Dachary over 4 years ago

upgrade

teuthology-suite --verbose --suite upgrade/hammer --suite-branch hammer --ceph hammer-backports --machine-type vps --priority 1000 machine_types/vps.yaml

#51 Updated by Loic Dachary over 4 years ago

rados OpenStack

ceph-workbench --verbose ceph-qa-suite --suite rados --ceph-git-url http://github.com/ceph/ceph --ceph hammer-backports --ceph-qa-suite-git-url http://github.com/ceph/ceph-qa-suite --suite-branch hammer --subset $(expr $RANDOM % 1000)/1000 --upload

INFO:teuthology.suite:Passed subset=410/1000

Re-running failed tests

#52 Updated by Loic Dachary over 4 years ago

upgrade openstack

ceph-workbench --verbose ceph-qa-suite --suite upgrade/hammer --ceph-git-url http://github.com/ceph/ceph --ceph hammer-backports --ceph-qa-suite-git-url http://github.com/ceph/ceph-qa-suite --suite-branch hammer --subset $(expr $RANDOM % 100)/100 --upload

#53 Updated by Loic Dachary over 4 years ago

rbd openstack

ceph-workbench --verbose ceph-qa-suite --suite rbd --ceph-git-url http://github.com/ceph/ceph --ceph hammer-backports --ceph-qa-suite-git-url http://github.com/ceph/ceph-qa-suite --suite-branch hammer --subset $(expr $RANDOM % 100)/100 --upload distros/supported/ubuntu_14.04.yaml

#54 Updated by Loic Dachary over 4 years ago

fs openstack

ceph-workbench --verbose ceph-qa-suite --suite fs --ceph-git-url http://github.com/ceph/ceph --ceph hammer-backports --ceph-qa-suite-git-url http://github.com/ceph/ceph-qa-suite --suite-branch hammer --subset $(expr $RANDOM % 100)/100 --upload

Re-running failed jobs

#55 Updated by Loic Dachary over 4 years ago

  • Description updated (diff)

#56 Updated by Loic Dachary over 4 years ago

  • Description updated (diff)

#57 Updated by Loic Dachary over 4 years ago

  • Description updated (diff)

#58 Updated by Loic Dachary over 4 years ago

  • Description updated (diff)

#59 Updated by Nathan Cutler over 4 years ago

  • Description updated (diff)

Last lead has approved for QA to start testing.

#60 Updated by Nathan Cutler over 4 years ago

  • Description updated (diff)

#61 Updated by Yuri Weinstein over 4 years ago

QE VALIDATION (STARTED 4/26/16)

(Note: PASSED / FAILED - indicates "TEST IS IN PROGRESS")

re-runs command lines and filters are captured in http://pad.ceph.com/p/hammer_v0.94.7_QE_validation_notes

Suite Runs/Reruns Notes/Issues
rados http://pulpito.ceph.com/teuthology-2016-04-25_09:00:02-rados-hammer-distro-basic-vps/ PASSED
http://pulpito.ceph.com/teuthology-2016-04-26_09:47:03-rados-hammer-distro-basic-smithi/
rbd http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-24_15:00:01-rbd-hammer-distro-basic-openstack/ PASSED
http://pulpito.ceph.com/teuthology-2016-04-26_10:30:18-rbd-hammer-distro-basic-smithi/
rgw http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-24_16:02:02-rgw-hammer-distro-basic-openstack/ PASSED
http://pulpito.ceph.com/teuthology-2016-04-26_10:42:04-rgw-hammer-distro-basic-smithi/
http://pulpito.ceph.com/teuthology-2016-04-26_14:09:13-rgw-hammer-distro-basic-mira/
fs http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-24_17:00:01-fs-hammer---basic-openstack/ FAILED #14716 same as in v0.94.6 see #13356
http://pulpito.ceph.com/teuthology-2016-04-26_13:25:57-fs-hammer---basic-mira/
http://pulpito.ceph.com/teuthology-2016-05-02_13:04:23-fs-hammer---basic-smithi/
http://pulpito.ceph.com/teuthology-2016-05-03_08:03:02-fs-hammer---basic-smithi/
krbd http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-24_18:06:02-krbd-hammer-testing-basic-openstack/ FAILED approved by Jason see note below
http://pulpito.ceph.com/teuthology-2016-04-26_13:29:02-krbd-hammer-testing-basic-mira/
http://pulpito.ceph.com/teuthology-2016-05-03_09:36:25-krbd-hammer-testing-basic-vps/
http://pulpito.ceph.com/yuriw-2016-05-05_08:25:55-krbd-hammer-testing-basic-mira/

Note from Jason: "This should not block the release.
xfs test cases 020, 206, and 229 also failed in v0.94.6
(http://tracker.ceph.com/issues/14717). The new failure is xfs/050
which appears to be a quota test case. Specifically it fails trying
to use project quotas, so this is a v4.6 kernel/xfs issue not a krbd
issue (last release was tested against kernel v4.5)."

kcephfs http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-24_19:08:02-kcephfs-hammer-testing-basic-openstack/ PASSED
http://pulpito.ceph.com/teuthology-2016-04-26_13:31:45-kcephfs-hammer-testing-basic-mira/
http://pulpito.ceph.com/teuthology-2016-05-02_13:12:13-kcephfs-hammer-testing-basic-mira/
knfs http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-24_20:10:01-knfs-hammer-testing-basic-openstack PASSED
hadoop http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-24_23:12:02-hadoop-hammer---basic-openstack PASSED
samba http://pulpito.ceph.com/teuthology-2016-04-26_13:34:00-samba-hammer---basic-smithi/ FAILED #14714 same as in v0.94.6 see #13356
http://pulpito.ceph.com/teuthology-2016-04-26_15:00:49-samba-hammer---basic-smithi/
rest http://pulpito.ceph.com/teuthology-2016-04-26_13:35:25-rest-hammer---basic-smithi/ PASSED
ceph-deploy http://pulpito.ceph.com/teuthology-2016-04-26_13:36:53-ceph-deploy-hammer-distro-basic-mira/ FAILED #14223
same as in v0.94.6 see #13356
vps http://pulpito.ceph.com/teuthology-2016-04-26_14:31:03-ceph-deploy-hammer-distro-basic-vps/
upgrade/client-upgrade http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-24_21:11:01-upgrade:client-upgrade-hammer-distro-basic-openstack PASSED
upgrade/dumpling-firefly-x http://pulpito.ceph.com/yuriw-2016-04-26_14:12:28-upgrade:dumpling-firefly-x-hammer-distro-basic-vps/ PASSED (ubuntu) packaging problem, centos failed + vps out of memory
http://pulpito.ceph.com/teuthology-2016-05-02_13:20:27-upgrade:dumpling-firefly-x-hammer-distro-basic-mira/
upgrade/firefly-x (hammer) http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-26_21:14:21-upgrade:firefly-x-hammer-distro-basic-openstack/ PASSED
http://pulpito.ceph.com/teuthology-2016-04-26_18:51:07-upgrade:firefly-x-hammer-distro-basic-mira/
http://pulpito.ceph.com/teuthology-2016-05-03_08:17:18-upgrade:firefly-x-hammer-distro-basic-mira/
http://pulpito.ceph.com/yuriw-2016-05-05_08:29:29-upgrade:firefly-x-hammer-distro-basic-mira/
upgrade/hammer http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-24_20:05:02-upgrade:hammer-hammer-distro-basic-openstack/ PASSED
http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-26_21:17:49-upgrade:hammer-hammer-distro-basic-openstack/
upgrade/hammer-x (infernalis) http://pulpito.ceph.com/teuthology-2016-04-24_17:10:02-upgrade:hammer-x-infernalis-distro-basic-vps/ PASSED
http://pulpito.ceph.com/teuthology-2016-05-03_08:24:09-upgrade:hammer-x-infernalis-distro-basic-vps/
http://pulpito.ceph.com/yuriw-2016-05-05_08:31:53-upgrade:hammer-x-infernalis-distro-basic-vps/
http://pulpito.ceph.com/yuriw-2016-05-05_13:48:49-upgrade:hammer-x-infernalis-distro-basic-smithi/
upgrade/firefly-hammer-x (infernalis) http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-04-26_11:18:06-upgrade:firefly-hammer-x-infernalis-distro-basic-openstack/ PASSED
http://pulpito.ceph.com/teuthology-2016-05-02_13:31:13-upgrade:hammer-x-infernalis-distro-basic-mira/
powercycle http://pulpito.ceph.com/teuthology-2016-04-26_09:53:14-powercycle-hammer-testing-basic-mira/ PASSED
http://pulpito.ceph.com/teuthology-2016-04-26_18:47:22-powercycle-hammer-testing-basic-mira/
(DON'T REMOVE BELOW)
Suite Runs/Reruns Notes/Issues
PASSED / FAILED

#62 Updated by Yuri Weinstein over 4 years ago

  • Description updated (diff)

#63 Updated by Yuri Weinstein over 4 years ago

  • Description updated (diff)

#64 Updated by Yuri Weinstein over 4 years ago

  • Description updated (diff)

#65 Updated by Loic Dachary about 4 years ago

  • Description updated (diff)
  • Status changed from In Progress to Resolved

Also available in: Atom PDF