Project

General

Profile

Bug #14638

Widespread package install failures in sepia

Added by Greg Farnum over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
-
Start date:
02/04/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

http://pulpito.ceph.com/gregf-2016-02-03_09:19:17-fs-greg-fs-testing-23---basic-mira/4638/

2016-02-03T12:52:07.361 INFO:teuthology.task.ansible.out:failed: [mira061.front.sepia.ceph.com] => (item=libgoogle-perftools4,libboost-thread1.54.0,mpich,qemu-system-x86,lttng-tools,libfcgi0ldbl,python-virtualenv,python-dev,libevent-dev,perl,libwww-perl,lsb-release,build-
essential,sysstat,gdb,python-configobj,python-gevent,libedit2,libssl0.9.8,cryptsetup-bin,xfsprogs,gdisk,parted,smbios-utils,libcrypto++9,libuuid1,libfcgi,btrfs-tools,libatomic-ops-dev,git-core,attr,dbench,bonnie++,iozone3,valgrind,python-nose,mpich2,libmpich2-dev,ant,libt
ool,automake,gettext,uuid-dev,libacl1-dev,bc,xfsdump,dmapi,xfslibs-dev,libattr1-dev,quota,libcap2-bin,libncurses5-dev,lvm2,sysprof,vim,pdsh,collectl,blktrace,python-numpy,python-matplotlib,genisoimage,libjson-xs-perl,xml-twig-tools,default-jdk,junit4,tgt,open-iscsi,smartm
ontools,nagios-nrpe-server,cifs-utils,ipcalc,nfs-common,nfs-kernel-server) => {"failed": true, "item": "libgoogle-perftools4,libboost-thread1.54.0,mpich,qemu-system-x86,lttng-tools,libfcgi0ldbl,python-virtualenv,python-dev,libevent-dev,perl,libwww-perl,lsb-release,build-e
ssential,sysstat,gdb,python-configobj,python-gevent,libedit2,libssl0.9.8,cryptsetup-bin,xfsprogs,gdisk,parted,smbios-utils,libcrypto++9,libuuid1,libfcgi,btrfs-tools,libatomic-ops-dev,git-core,attr,dbench,bonnie++,iozone3,valgrind,python-nose,mpich2,libmpich2-dev,ant,libto
ol,automake,gettext,uuid-dev,libacl1-dev,bc,xfsdump,dmapi,xfslibs-dev,libattr1-dev,quota,libcap2-bin,libncurses5-dev,lvm2,sysprof,vim,pdsh,collectl,blktrace,python-numpy,python-matplotlib,genisoimage,libjson-xs-perl,xml-twig-tools,default-jdk,junit4,tgt,open-iscsi,smartmo
ntools,nagios-nrpe-server,cifs-utils,ipcalc,nfs-common,nfs-kernel-server"}
stderr: E: There are problems and -y was used without --force-yes

stdout: Reading package lists...
Building dependency tree...
Reading state information...
libfcgi0ldbl is already the newest version.

2016-02-03T12:52:07.363 INFO:teuthology.task.ansible.out:libdm0 is already the newest version.
The following extra packages will be installed:
  cpu-checker ipxe-qemu libbluetooth3 libbrlapi0.6 libcaca0
  libconfig-general-perl libfdt1 libibverbs1 librados2 librbd1 librdmacm1
  libsdl1.2debian libseccomp2 libsgutils2-2 libspice-server1
  libusbredirparser1 libxen-4.4 libxenstore3.0 libyajl2 msr-tools qemu-keymaps
  qemu-system-common qemu-utils seabios sg3-utils sharutils
Suggested packages:
  samba vde2 sgabios kvm-ipxe-precise debootstrap
The following NEW packages will be installed:
  cpu-checker ipxe-qemu libbluetooth3 libbrlapi0.6 libcaca0
  libconfig-general-perl libfdt1 libibverbs1 librados2 librbd1 librdmacm1
  libsdl1.2debian libseccomp2 libsgutils2-2 libspice-server1
  libusbredirparser1 libxen-4.4 libxenstore3.0 libyajl2 msr-tools qemu-keymaps
  qemu-system-common qemu-system-x86 qemu-utils seabios sg3-utils sharutils
  tgt
0 upgraded, 28 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/7111 kB of archives.
After this operation, 33.5 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libbluetooth3 librados2 librbd1 libsdl1.2debian libusbredirparser1
  libibverbs1 ipxe-qemu seabios tgt

http://pulpito.ceph.com/gregf-2016-02-03_09:19:17-fs-greg-fs-testing-23---basic-mira/4624/
http://pulpito.ceph.com/gregf-2016-02-03_09:19:17-fs-greg-fs-testing-23---basic-mira/4641/
http://pulpito.ceph.com/gregf-2016-02-03_09:19:17-fs-greg-fs-testing-23---basic-mira/4572/

History

#1 Updated by Zack Cerza over 3 years ago

Because it was left out of the report: this happened on Ubuntu 14.04

#3 Updated by Zack Cerza over 3 years ago

I've been trying to reproduce this since this morning and haven't been able to.

#4 Updated by Greg Farnum over 3 years ago

When I created this I erroneously thought I'd seen it in a run from earlier in the day, but that turns out not to be the case. So I'm not sure how widespread it actually is (although it's quite obvious that this isn't just about our gitbuilders, given the packages involved!).

#5 Updated by Dan Mick over 3 years ago

Since I looked: we could get some more output from apt if we added Debug::pkgAcquire::Auth to the apt configuration; sadly, it doesn't look like there's an easy way to do that with the apt Ansible module, but apt does support /etc/apt/apt.conf.d, so dropping in a config fragment there might work.

I also note the existence of APT::Get::AllowUnauthenticated that simply drives past these errors (there's also an --allow-unauthenticated commandline switch).

It might not be a bad idea to review apt.conf(5) and maybe add some Debug options unconditionally, given how often we get apt-related mysteries.

#6 Updated by Zack Cerza over 3 years ago

  • Project changed from sepia to ceph-cm-ansible

#7 Updated by Ian Colle almost 3 years ago

Is this still happening?

#8 Updated by Zack Cerza almost 3 years ago

  • Status changed from New to Closed

I haven't heard anything about it in ages. I think we can close it and drive on.

Also available in: Atom PDF