Project

General

Profile

Bug #14549

rgw: metadata api (rest) broken

Added by Yehuda Sadeh almost 7 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

s->bucket does not hold the path entry off /admin/<path> following a few multi-tenancy fixes.

Associated revisions

Revision d5ae7f86 (diff)
Added by Yehuda Sadeh almost 7 years ago

rgw: don't use s->bucket for metadata api path entry

Fixes #14549

s->bucket is only initialized at the object store handler (post auth
callback). We don't want to initialize it for other cases because
it's not a real bucket, and initializing it will require going through
the authorization path for this 'bucket'.

Signed-off-by: Yehuda Sadeh <>

Revision 00d396e3 (diff)
Added by Yehuda Sadeh almost 7 years ago

rgw: don't use s->bucket for metadata api path entry

Fixes #14549

s->bucket is only initialized at the object store handler (post auth
callback). We don't want to initialize it for other cases because
it's not a real bucket, and initializing it will require going through
the authorization path for this 'bucket'.

Signed-off-by: Yehuda Sadeh <>

History

#1 Updated by Casey Bodley over 2 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF