Project

General

Profile

Bug #14452

rbd-replay does not check for EOF and goes to endless loop

Added by Mykola Golub almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
hammer, infernalis
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

BufferReader::fetch() goes to endless loop because it does not check for EOF.


Related issues

Copied to rbd - Backport #14465: infernalis: rbd-replay does not check for EOF and goes to endless loop Resolved
Copied to rbd - Backport #14466: hammer: rbd-replay does not check for EOF and goes to endless loop Resolved

Associated revisions

Revision c59b84c3 (diff)
Added by Mykola Golub almost 7 years ago

rbd-replay: handle EOF gracefully

Fixes: #14452
Signed-off-by: Mykola Golub <>

Revision 24c0b27c (diff)
Added by Mykola Golub almost 7 years ago

rbd-replay: handle EOF gracefully

Fixes: #14452
Signed-off-by: Mykola Golub <>
(cherry picked from commit c59b84c3e2c9bbda68219e4d2288a889dd9ca6cb)

Conflicts:
src/rbd_replay/BufferReader.cc: trivial resolution
caused by s/CEPH_PAGE_SIZE/CEPH_BUFFER_APPEND_SIZE/
in the context of one hunk.

Revision 2c5b90a2 (diff)
Added by Mykola Golub almost 7 years ago

rbd-replay: handle EOF gracefully

Fixes: #14452
Signed-off-by: Mykola Golub <>
(cherry picked from commit c59b84c3e2c9bbda68219e4d2288a889dd9ca6cb)

History

#2 Updated by Jason Dillaman almost 7 years ago

  • Status changed from New to Pending Backport
  • Backport set to hammer, infernalis

#3 Updated by Loïc Dachary almost 7 years ago

  • Copied to Backport #14465: infernalis: rbd-replay does not check for EOF and goes to endless loop added

#4 Updated by Loïc Dachary almost 7 years ago

  • Copied to Backport #14466: hammer: rbd-replay does not check for EOF and goes to endless loop added

#5 Updated by Loïc Dachary almost 7 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF