Project

General

Profile

Bug #14399

"ReplicatedPG.cc: 10483: FAILED assert(obc)" in rados-hammer-distro-basic-mira

Added by Yuri Weinstein about 7 years ago. Updated almost 7 years ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rados
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Run: http://pulpito.ceph.com/teuthology-2016-01-17_09:00:09-rados-hammer-distro-basic-mira/
Jobs: ['31875', '31914']
Logs: http://qa-proxy.ceph.com/teuthology/teuthology-2016-01-17_09:00:09-rados-hammer-distro-basic-mira/31875/teuthology.log

2016-01-17T15:21:46.570 INFO:tasks.ceph.osd.5.mira066.stderr:     0> 2016-01-17 15:21:46.473009 7ffb6dcbc700 -1 osd/ReplicatedPG.cc: In function 'void ReplicatedPG::hit_set_trim(ReplicatedPG::RepGather*, unsigned int)' thread 7ffb6dcbc700 time 2016-01-17 15:21:46.465986
2016-01-17T15:21:46.570 INFO:tasks.ceph.osd.5.mira066.stderr:osd/ReplicatedPG.cc: 10483: FAILED assert(obc)
2016-01-17T15:21:46.570 INFO:tasks.ceph.osd.5.mira066.stderr:
2016-01-17T15:21:46.570 INFO:tasks.ceph.osd.5.mira066.stderr: ceph version 0.94.5-221-g4e67418 (4e67418958e5caf5e4f81c4ed566e8c7269930fa)
2016-01-17T15:21:46.570 INFO:tasks.ceph.osd.5.mira066.stderr: 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x8b) [0xba856b]
2016-01-17T15:21:46.571 INFO:tasks.ceph.osd.5.mira066.stderr: 2: (ReplicatedPG::hit_set_trim(ReplicatedPG::RepGather*, unsigned int)+0x72f) [0x86774f]
2016-01-17T15:21:46.571 INFO:tasks.ceph.osd.5.mira066.stderr: 3: (ReplicatedPG::hit_set_persist()+0xfcc) [0x86883c]
2016-01-17T15:21:46.571 INFO:tasks.ceph.osd.5.mira066.stderr: 4: (ReplicatedPG::do_op(std::tr1::shared_ptr<OpRequest>&)+0xe2e) [0x88976e]
2016-01-17T15:21:46.571 INFO:tasks.ceph.osd.5.mira066.stderr: 5: (ReplicatedPG::do_request(std::tr1::shared_ptr<OpRequest>&, ThreadPool::TPHandle&)+0x66a) [0x826d2a]
2016-01-17T15:21:46.571 INFO:tasks.ceph.osd.5.mira066.stderr: 6: (OSD::dequeue_op(boost::intrusive_ptr<PG>, std::tr1::shared_ptr<OpRequest>, ThreadPool::TPHandle&)+0x3bd) [0x69615d]
2016-01-17T15:21:46.572 INFO:tasks.ceph.osd.5.mira066.stderr: 7: (OSD::ShardedOpWQ::_process(unsigned int, ceph::heartbeat_handle_d*)+0x338) [0x696688]
2016-01-17T15:21:46.572 INFO:tasks.ceph.osd.5.mira066.stderr: 8: (ShardedThreadPool::shardedthreadpool_worker(unsigned int)+0x85f) [0xb980bf]
2016-01-17T15:21:46.572 INFO:tasks.ceph.osd.5.mira066.stderr: 9: (ShardedThreadPool::WorkThreadSharded::entry()+0x10) [0xb9a1e0]
2016-01-17T15:21:46.572 INFO:tasks.ceph.osd.5.mira066.stderr: 10: (()+0x8182) [0x7ffb8b487182]
2016-01-17T15:21:46.572 INFO:tasks.ceph.osd.5.mira066.stderr: 11: (clone()+0x6d) [0x7ffb899f200d]
2016-01-17T15:21:46.573 INFO:tasks.ceph.osd.5.mira066.stderr: NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

Related issues

Related to Ceph - Bug #13185: osd/ReplicatedPG.cc: 11062: FAILED assert(obc) on hammer -> infernalis upgrade Resolved 09/21/2015
Related to Ceph - Bug #13811: "osd/ReplicatedPG.cc: 10525: FAILED assert(obc)" in upgrade:firefly-hammer-x-jewel-distro-basic-openstack Can't reproduce 11/16/2015
Related to Ceph - Backport #12848: ReplicatedPG::hit_set_trim osd/ReplicatedPG.cc: 11006: FAILED assert(obc) Resolved
Duplicates Ceph - Bug #9732: ReplicatedPG::hit_set_trim osd/ReplicatedPG.cc: 11006: FAILED assert(obc) Resolved 10/10/2014

History

#1 Updated by Yuri Weinstein about 7 years ago

  • Related to Bug #13185: osd/ReplicatedPG.cc: 11062: FAILED assert(obc) on hammer -> infernalis upgrade added

#2 Updated by Yuri Weinstein about 7 years ago

  • Related to Bug #13811: "osd/ReplicatedPG.cc: 10525: FAILED assert(obc)" in upgrade:firefly-hammer-x-jewel-distro-basic-openstack added

#3 Updated by Samuel Just about 7 years ago

  • Priority changed from Normal to Urgent

#4 Updated by Yuri Weinstein about 7 years ago

More in run:
http://pulpito.ceph.com/teuthology-2016-01-18_09:00:08-rados-hammer-distro-basic-mira/
Jobs: ['32573', '32584', '32607', '32615', '32626', '32637']

#5 Updated by Samuel Just about 7 years ago

  • Related to Backport #12848: ReplicatedPG::hit_set_trim osd/ReplicatedPG.cc: 11006: FAILED assert(obc) added

#6 Updated by Samuel Just about 7 years ago

  • Duplicates Bug #9732: ReplicatedPG::hit_set_trim osd/ReplicatedPG.cc: 11006: FAILED assert(obc) added

#7 Updated by Yuri Weinstein about 7 years ago

Per chat in IRC with Sam "simplest solution in the short term would be to fix the miras to be on the same timezone" as it relates to the latest update in this ticket

#8 Updated by Kefu Chai about 7 years ago

  • Assignee set to Kefu Chai

#9 Updated by Kefu Chai almost 7 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF