Project

General

Profile

Bug #14319

Double decreased the count to trim caps which will cause failing to respond to cache pressure

Added by Zhi Zhang almost 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

When reaching mds cache size, mds will ask clients to trim its own caps. In ceph-fuse, it will recalculate current caps size for each loop, so it double decreases the loop counts. Hence at most time, ceph-fuse client only trims half of expected caps number. MDS often reports the warning of failing to respond to cache pressure and have to wait for asking client to trim caps next time.


Related issues

Copied to CephFS - Backport #15512: hammer: Double decreased the count to trim caps which will cause failing to respond to cache pressure Resolved

History

#2 Updated by Loïc Dachary almost 7 years ago

  • Target version deleted (v0.94.6)

#3 Updated by Samuel Just almost 7 years ago

  • Project changed from Ceph to CephFS
  • Category deleted (11)

#4 Updated by Zhi Zhang almost 7 years ago

  • Backport set to hammer

This issue also exists on master, so close original PR and create this new one.

https://github.com/ceph/ceph/pull/7229

#5 Updated by Greg Farnum over 6 years ago

  • Status changed from New to Pending Backport

Whoops, this got merged in way back then in January!

Looks like no backport got scheduled or anything; we'll see if it makes it — there are plenty of other reasons to upgrade to Jewel when using CephFS!

#6 Updated by Nathan Cutler over 6 years ago

  • Copied to Backport #15512: hammer: Double decreased the count to trim caps which will cause failing to respond to cache pressure added

#7 Updated by Loïc Dachary over 6 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF